gnome-panel не загружается

@linux-lukc:/usr/bin> gnome-panel
Warning: program compiled against libxml 207 using older 206

(gnome-panel:13739): Bonobo-Activation-CRITICAL **: bonobo_activation_query: assertion `ac != NULL' failed
Segmentation fault

Если запускаю как su, то:

linux-lukc:/ # gnome-panel

** (gnome-panel:13667): WARNING **: Cannot register the panel shell: The connection is closed

Software Management, также не запускается. Всё это началось как будто после удаления Оперы. Версия GNOME - 2.

rpm -qa | grep libxml
gnome-about (версия)
:idea: протестируйте под новым юзером

Создал юзера командой useradd.
В текстовой версии YaST убрал автологин старого пользователя.
Перезагрузил.

Теперь загрузка системы останавливается тогда, когда нужно выбрать пользователя, но окошко выбора отсутствует. Загрузить иксы не удаётся. Перейти в текстовый режим по Ctrl+Alt+F1 возможно.

Версия GNOME - 2.32.1.

логи теперь… сюда целиком заливать не нужно :slight_smile:
~/.xsession-errors
cat /var/log/Xorg.0.log | grep EE

И зачем useradd, когда есть yast2 users?

  • Каталог /home/New_User появился?

Пользовался useradd, потому что графический yast не запускался, а о существовании текстовой версии я тогда не знал.
Создал ещё одного пользователя в текстовом yast’е, под его логином и эксперементировал. Каталог /home/New_User появился. Под новым пользователем Ctrl+Alt+Del работает, под старым - нет.
Xorg.0.log xsession-errors

Ничего не грузится. Ну сколько же можно…

Господа модераторы: может быть стоит прикрепить тему Логи и Скриншоты Заливать Сюда](http://img.susepaste.org/)?

Xorg.0.log .xsession-errors](http://img.susepaste.org/10909469)

Логи ничего конкретного не показывают (или я не вижу). Но, учитывая

Всё это началось как будто после удаления Оперы.

можно открыть Менеджер ПО, выбрать Дополнительно > Посмотреть историю, найти искомый момент удаления и проанализировать, какие действия были до/после этого.

можно открыть Менеджер ПО

А как его открыть? В текстовом yast’е он по-прежнему не запускается.

Software Management, также не запускается.

S | Name                | Type       | Version       | Arch   | Repository
--+---------------------+------------+---------------+--------+---------------------------------
v | libxml2             | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-11.4-0
i | libxml2             | package    | 2.7.8-16.17.1 | x86_64 | Updates for openSUSE 11.4 11.4-0
v | libxml2             | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-Oss
v | libxml2             | package    | 2.7.8-16.17.1 | i586   | Updates for openSUSE 11.4 11.4-0
v | libxml2             | package    | 2.7.8-15.1    | i586   | openSUSE-11.4-Oss
  | libxml2             | srcpackage | 2.7.8-16.17.1 | noarch | Updates for openSUSE 11.4 11.4-0
  | libxml2             | patch      | 4811          | noarch | Updates for openSUSE 11.4 11.4-0
i | libxml2-32bit       | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-11.4-0
v | libxml2-32bit       | package    | 2.7.8-16.17.1 | x86_64 | Updates for openSUSE 11.4 11.4-0
i | libxml2-32bit       | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-Oss
  | libxml2-devel       | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-11.4-0
  | libxml2-devel       | package    | 2.7.8-16.17.1 | x86_64 | Updates for openSUSE 11.4 11.4-0
  | libxml2-devel       | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-Oss
  | libxml2-devel       | package    | 2.7.8-16.17.1 | i586   | Updates for openSUSE 11.4 11.4-0
  | libxml2-devel       | package    | 2.7.8-15.1    | i586   | openSUSE-11.4-Oss
  | libxml2-devel-32bit | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-11.4-0
  | libxml2-devel-32bit | package    | 2.7.8-16.17.1 | x86_64 | Updates for openSUSE 11.4 11.4-0
  | libxml2-devel-32bit | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-Oss
  | libxml2-doc         | package    | 2.7.8-16.17.1 | noarch | Updates for openSUSE 11.4 11.4-0
  | libxml2-doc         | package    | 2.7.8-15.1    | noarch | openSUSE-11.4-Oss
i | libxml2-python      | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-11.4-0
i | libxml2-python      | package    | 2.7.8-15.1    | x86_64 | openSUSE-11.4-Oss
v | libxml2-python      | package    | 2.7.8-15.1    | i586   | openSUSE-11.4-Oss

Возможно, удаление лишних пакетов решило бы проблему, но я не знаю как выбрать именно их.

Это извиняюсь что?

Боюсь, где-то в ваших предыдущих действиях был конкретная ошибка, которую найти теперь затруднительно. Чтобы не терять зря время, устанавливайте 12.1, если ничего против Gnome 3 не имеете… заодно и в тестировании системы можете помочь :slight_smile: Я конечно не советую третий, но с другой стороны и не знаю, как можно было второй- практически идеально вылизанный DE- убить, так что…

Можно попробовать переустановить пакеты:


zypper in --force libxml2 libxml2-32bit libxml2-python

Можно попробовать переустановить пакеты:


zypper in --force libxml2 libxml2-32bit libxml2-python

Это то, как zypper видит список установленных libxml2 (включающих libxml).

Против третьего пока ничего конкретно не имею, т.к. им ещё не пользовался :slight_smile: Но очень хотел посмотреть на второго, пока он жив. К тому же, если начну качать бету, то закончу примерно к выходу релиза. Вообще же, при выборе DE учитываю прежде всего удобство настройки и использования, стабильность, легковесность.
Систему переустановил. Много не потерял, т.к. установка была эксперементальной.