gnome panel sensors applet

I installed the gnome panel sensors applet for openSUSE 11 x86_64, but it isn’t in the “add to panel” list. I checked to see where it was installed: /usr/lib/sensors-applet. Do I still need to compile it using ./configure --prefix=/usr?

I used YaST to install the applet, but when I was looking for where it was installed, I found a readme file in /usr/share/doc/packages/sensors-applet that said :
"Debian, Fedora, Ubuntu and most standard distro users will need to do a

./configure --prefix=/usr

to ensure proper installation within the correct path."

The readme file also said :

  • GNOME 2.8 desktop environment, with GTK >=2.4.0 and libpanelapplet-2"
    …so I installed GNOME Panel development to provide libpanelapplet-2.

Are there any sensors detected?

Yes, I ran sensors-detect as root and loaded the dme1737-i2c-0-2e module. The XFCE sensors applet works just fine.

Did you install any other gnome applets that work?

Yes, the Netspeed and Deskbar applets, and they both show up on the “Add to panel” list

This is the list of files installed by YaST:

Just thought I would post a confirmation that this package is indeed broken with OpenSuse 11 64 bit. Ironically, it works fine with my installation of 11 32 bit though. Thus, my assumption is that this is probably a packing error. So, the running tally of known 64 bit applet bugs so far is:

  • Gnome-sensors-applet - (64 bit)
  • CPU scaling applet - (both 64 and 32 bit)
  • CPU temp applet (64 bit)

If any one learns of further details, please post. In the mean time, I will check Bugzilla to see if these bugs have been reported.

Thanks j_black!

Gnome sensors-applet package for 64bit isn’t broken. It simply doesn’t exist. Check site and you will find packages for 32 bit only. I tried to build my own package from src.rpm but I couldn’t find gnome-applets-devel package for openSUSE 11 64bit.

Thanks for the post. You are correct, it turns out that I installed the i586 version without realizing it. To be honest, I am surprised that this type of mistake is even possible. With CentOS or Debian, the package managers enforce arch unless noarch is specified. I guess I need to chalk this up to something else learned about OpenSuse. (Yes, I am new convert to OpenSuse 11 after years of RedHat/RHEL versions on servers).

Any way, thanks. I will take a stab at packing the applets up too.

Install sensors-applet 2.2.1-37.7@i586 via yast or download the sources from here GNOME Sensors Applet Homepage and compile it

after that, try this:

cd /usr/lib64/bonobo/servers/
ln -sf /usr/lib/bonobo/servers/SensorsApplet.server
cd /usr/lib64/
ln -sf …/lib/libsensors-applet-plugin.a
ln -sf …/lib/
ln -sf …/lib/
ln -s
ln -s

It worked for my rotfl!

(sorry for mi bad english)