Gnome Panel not starting

When I boot my computer in the default configuration the panel toolbar, typically at the bottom of the screen, does not appear. When I restart it, before shutting down a message appears asking me if I want to kill the Panel program which is not responding. Curiously, the panel appears when I boot in the pae configuration. I am not really sure what is the pae configuration or why it would work then.

I am running on a Lenovo x61 laptop with OpenSuse 11.3, completely updated with all the most recent bug fixes and patches.

On a possibly unrelated note, the battery just died on my laptop, as in it will no longer charge and discharge, and I am running on pure AC power. The tool in the panel insists that the battery is there and fully charged. Is it possible that the panel is not starting because sometimes it is waiting for a response from my dead battery?

Thanks for any help.

Hi
If you open the Control Center and look at the startup applications you
can disable the power management applet from starting and see if that
helps.
Else try restarting;


kill -HUP `pidof gnome-panel`


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.24-0.2-default
up 2 days 15:19, 2 users, load average: 1.06, 0.51, 0.24
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

Ok so disabling the power management applet did not fix the problem.

When I first startup I am able to restart the gnome-panel with the kill command and the bar appears.

When I restart the computer again the panel does not appear and I have to manually restart it. Any suggestions for a more permanent fix? Should I submit a bug report somewhere?

Thanks,
Ken

Try to create a new user for testing purpose. Logout and login in Gnome as this user. Does the panel appear for him?

The panel appears immediately for my new user.

When I login again to my usual user the panel does not appear and I have to start it manually.

However, seems to be intermittent, as sometimes the panel appears after logging in and out a few times…

Hi
Is there something you added to the panel that doesn’t appear to work?

What happens if you move the panel to another position and logout/login?

Run up gconf-editor and inspect the panel settings.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.24-0.2-default
up 3 days 0:24, 2 users, load average: 0.03, 0.04, 0.02
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

Only the basics are in the panel: main menu, display settings, sound, networking, workspaces, date/time and clear desktop button. All seem to work fine also.

I disabled the power management applet in the Control Center, should I have done the same in gconf-editor? If so I do not see where I am suppose to do that.

Moving the panel does not solve the problem.

It turns out that after a week an error message popped up when I began my session saying that the Tomboy applet was causing an error in the Gnome panel. I opted to delete the applet since I do not use Tomboy and have not had any problems since.