Gnome Onscreen Keyboard Needs Double-tap in Firefox with Wayland to Pop-up

Hello all,

I have a kiosk I’m working on that needs an On-screen keyboard. Originally I had planned on using Onboard, but it has its own issues with sometimes not auto-hiding when it should and the settings options being available to anybody to manipulate.

I’ve started playing with a combination of Gnome+Gnome’s OSK+Firefox in kiosk mode+Wayland. This is almost perfect, except for 2 issues:

  1. The Gnome OSK requires a double-tap in a text field to pop-up, which isn’t intuitive. Is there anyway to adjust these settings or workaround this issue? I’ve looked in gsettings and didn’t see anything that would help me here. I’ve thought about figuring out a way to make any tap a double-click, but I’d like to avoid that if possible - if I did attempt this, would that be accomplished through xinput? Does xinput even work with Wayland or is there an alternative?

  2. The height of the keyboard far extends past the keys while in portrait mode. I’ve seen some extensions that can lower this (https://extensions.gnome.org/extension/4413/improved-osk/), but they don’t seem to work with my current setup/version.

Any help with this is much appreciated.