GNOME only shows black screen and mouse pointer

Hi!

When I try to log into Gnome (default version that ships with Leap 15) I only get a black screen and a mouse pointer. The syslogs have the following entry

gnome-session-binary[12407]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 5

The full logs can be found here: https://pastebin.com/mA21Y24Y

It seems (I don’t have any experience in debugging gnome) that the gnome-shell is killed, but I don’t know why or which process kills it. Does anyone know how to find some more information on this problem or how to solve it?

Hi, from your log you are apparently using the SDDM display manager: is this a KDE / Gnome dual install or do you have a specific reason for not running GDM with Gnome?
In your logs there are many errors from baloo; I don’t know if that might be related, but just to be sure can you disable or uninstall baloo and see if you still have problems with gnome-shell?

It is a dual install since I need a running system, and KDE works (more or less).

I tried to stop baloo via

balooctl stop

and tried to log into gnome, but the many many baloo-related errors are still there. If I try to uninstall baloo, yast wants to uninstall the entire KDE, which is no option since I need a running system. Killing the gnome shell occurs some time before the baloo errors, so I guess it is not related.

Some more info: It does not matter if I try gnome with wayland, Xorg or even classic. Second, I’m running quite new hardware (Thinkpad P52).

Okay, I found a way to disable baloo, the problem remains. Here are the logs https://paste.opensuse.org/a53faa62

Little experience here with dual installs, sorry. Better wait for an answer by somebody routinely using such a setup.
You are running unusual HW (Xeon+Nvidia Quadro?): to help us understand the exact configuration please post the results of the following commands in a terminal with superuser privileges:


# lspci -nnk |grep -EA 3 "VGA|3D|Display"
# lscpu |grep Model

Here is the output as requested.


athenry:/home/patta # lspci -nnk |grep -EA 3 "VGA|3D|Display" 
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
        Subsystem: Lenovo Device [17aa:225f]
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1cba] (rev ff)
        Kernel modules: nouveau, nvidia_drm, nvidia
70:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
        Subsystem: Lenovo Device [17aa:225f]
athenry:/home/patta # lscpu |grep Model
Modell:                        158
Modellname:                    Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz

I have posted some more information in this forum when I was trying to install bumblebee on this laptop. here is the thread: https://forums.opensuse.org/showthread.php/533324-Getting-bumblebee-to-work-on-a-Lenovo-P52 That is the configuration that I am currently running.

Well, not only you have a Nvidia Quadro of the Pascal series but the system provides two full VGA adapters, not the usual “Optimus” configuration with all outputs wired through the Intel chip…
Maybe this has also something to do with your troubles installing bumblebee (I’m actually surprised that bumblebee works at all).
All that is definitely above my pay grade :
Apparently in some markets that workstation comes with Ubuntu pre-installed: if that is your case maybe you can get some tips from the pre-installed Ubuntu configuration.
Or is there an entry in the firmware (BIOS) to disable one or the other of the two VGA adapters?

I have bought this machine since I was very satisfied with my previous W530, which offered three modes in the BIOS: Onboard (Intel) graphics, NVIDIA graphics or Optimus. In the few cases I really need the NVIDIA card (when giving a talk or running some heavy simulations, I usually do not need to carry the laptop, and I just booted it with nvidia, changed the Xorg.conf and everything was fine.

Now, this machine only offers two options: NVIDIA or Optimus. Since most of the time I only need the Intel card (and battery life), I am happy that bumblebee works and I can also use the NVIDIA card if I need it. But it is really annoying that GNOME does not work. KDE plasma does not work perfect at all (there are maaaaaany problems with the plasma-related apps: I can’t scroll properly, they freeze), but since I’m used to using a terminal, KDE plasma provides a system that I can work with. But I’d love to have a system that really works well, and I thought maybe GNOME (which is my favourite anyway) would not have these tiny problems, once I get it to work.

I don’t have a pre-installed ubuntu (wouldn’t have deleted it if I had it). They say that it ships with some “vendor-specific adaptions”, whatever that means.

thanks for your help anyway.

OK, so to the benefit of others willing to help we are dealing here with an Optimus configuration with bumblebee and presumably booting using the integrated GPU.

But it is really annoying that GNOME does not work. KDE plasma does not work perfect at all (there are maaaaaany problems with the plasma-related apps: I can’t scroll properly, they freeze),

That tells us that there is something in the configuration that might be unusual, likely related to graphics and since you are apparently using Intel most of the time it might be related to the UHD630 having new features not necessarily enabled by default by the Leap kernel 4.12.
Usually avoiding Wayland (use Gnome on X11 at login) and using the OpenGL2.0 or X11 compositors with KDE might help here.

But I’d love to have a system that really works well, and I thought maybe GNOME (which is my favourite anyway) would not have these tiny problems, once I get it to work.

May I suggest that you try the latest Tumbleweed live DVD (whether in the Gnome or KDE flavour) and see if you experience the same troubles with those up to date kernel and graphics stack?

I don’t have a pre-installed ubuntu (wouldn’t have deleted it if I had it). They say that it ships with some “vendor-specific adaptions”, whatever that means.

… those we were interested in :wink: most likely updated graphics drivers or scripts to switch from Intel to Nvidia graphics.

With Leap 15 I think you have to boot with the “i915.alpha_support=1” kernel option (please ask if you need help); maybe that is not necessary with the latest Tumbleweed, but I cannot check ATM.

Booting with this option does not help. I’ll try the tumbleweed-live DVD (as soon as I find a USB-stick).

I’ve tried Tumbleweed live (GNOME) now, but it just reboots after some time. I think, net I will try to get gdm running, maybe that produces some more helpful error messages.

Hu, success :slight_smile:

It seems that since my last attempts to get gdm running some updates have been released. I just installed gdm, uninstalled sddm (I cannot select a display manager via yast’s sysconfig editor), and it works like a charm. I can even log into gnome and use it.

Nice to see that you are up and running with Gnome :slight_smile:
Indeed on Nov. 30 a new X-server became available (version 1.19.6) and that might be related.

FYI:

The way to change Display Managers now is:

su -
update-alternatives --config default-displaymanager

Fraser Bell wrote:

>
> patta42;2888181 Wrote:
>> Hu, success :slight_smile:
>>
>> It seems that since my last attempts to get gdm running some updates
>> have been released. I just installed gdm, uninstalled sddm (I cannot
>> select a display manager via yast’s sysconfig editor), and it works
>> like a charm. I can even log into gnome and use it.
>
> FYI:
>
> The way to change Display Managers now is:
>
> Code:
> --------------------
> su -
> update-alternatives --config default-displaymanager
> --------------------
>
>
Yes, indeed. Any idea why yast continues to offer non-operative options?


*********** To reply by e-mail, make w single in address **************