Gnome on X not working

Hi all,

Bit of an odd issue. Normally I leave my computer on, but I turned it off last night. When I tried to log in this morning, Gnome failed to load and put me right back to the login screen. I think there are some error messages displayed but they’re too quick to read and I’m not sure where they are logged…

Gnome on Wayland works fine. If I log in as another user it works fine. So it’s just my user.

I’ve tried disabling extensions to no avail. I don’t have any custom commands in .xinitrc. I updated Tumbleweed to the latest packages.

Does anyone have any suggestions on where to look next?



Use the command journalctl -b to see what is happening, also ~/.local/var/log/Xorg… (On Tumbleweed the xorg logs are now in userspace).

Thank you! I just couldn’t find the logs. Found and fixed the error (a permissions problem). I really appreciate your help! :smiley:

Do you ever log into a GUI as root? doing so can cause permission problems in a users home that is browsed.