Gnome NetworkManager Icon Gone From System Tray???

Hello all,

OpenSuSE 11.4 — #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux

So recently in the last couple of days my NetworkManager Icon has disappeared from the “System Tray” on the Taskbar, even after a reboot.

I have tried doing: Alt+F2 then typing “nm-applet” and nothing happens.
Also tried in the terminal typing “nm-applet” and I get:

# nm-applet
An instance of nm-applet is already running.

I am connected to the internet so I know it is working but how do I get the icon back? I would like to be able to switch between connection types (i.e. wlan0 or eth0 etc…) but can’t do it without it (well easily anyway, probably could switch through the terminal but I would rather not).

Also, on another note I remember earlier in the week reading a post that someone had the same problem, and they told him to Alt-F2 and type “nm-applet”, which did work for me once but now it is not.

***And I do remember accidentally deleting something involving NetworkManager from the “Startup Applications” app. Can’t remember exactly what it said but I do remember it had the word “-disable” at the end of the command. → If anyone has NetworkManager icon in their system tray could you please look at your “Startup Applications” and tell me what the one for NetworkManager’s command says??

Any suggestions would be greatly appreciated.

Thanks in advance,

Mine says:

nm-applet --sm-disable

Open gnome-session-properties and then check the list for an entry
called Network, else select ‘Add’

Name: Network
Command: nm-applet --sm-disable
Comment: Manage your network connections

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 3 days 3:06, 3 users, load average: 0.18, 0.19, 0.13
GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06

MalcomLewis & Yasar,

That’s it!!! Thanks guys… I will add that to my startup applications and I’ll see what happens.

Thanks, you guys are awesome,

Hey guys,

I think I may have jumped the gun a bit… It’s still not showing up? Is there anything else involving NetworkManager in the Start Applications list? I came across this looking around in “Software Management” after searching for “NetworkManager” :


Do you know if that has anything to do with it either? I may be remembering wrong but wasn’t there two things in “Startup Applications” involving NetworkManager?


Ok, so I’ve been looking around a bit on my laptop and I found ‘nm-connection-editor’, I ran it from the terminal and it opens the dialog box that appears when you R-click on the NetworkManager icon and click “Edit Connections.” This is what happened:

mmartin:/usr/lib/ModemManager # nm-connection-editor

** (nm-connection-editor:17118): WARNING **: get_all_cb: couldn't retrieve system settings properties: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.

** (nm-connection-editor:17118): WARNING **: fetch_connections_done: error fetching system connections: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.

Even though I get those errors the app still opens but it is EMPTY* (no connections listed in any tab)*!

Yesterday and today when I booted my laptop I noticed I got these two popup boxes just before the login screen. They read:
First one:

Could not create ICE listening Socket:
Cannot establish any listening sockets.

Second one:

ICEListenForConnections did not return a local listener!

I have no idea what they were for but I am starting to think that maybe NetworkManager is not controlling my internet connections anymore, because even though it showed no connections, I am currently on the internet?

If there’s anything else you guys can think of, PLEASE let me know… And if I figure it out in the mean time I’ll let you know. Maybe my best bet would be to just reinstall all the NetworkManager stuff in “Software Management.” We’ll see though.


Can you create a test user and login as that test user, does the nm applet appear? You could also check via YaST Network Devices to see if it’s controlled via YaST or the NetworkManger.

Hey Malcom,

Thank you, Thank you, Thank you!!! That worked (YaST > Network Devices > changed to NetworkManager)!!!

It was as I suspected… It wasn’t being controlled by NetworkManager, just didn’t know how to change who was controlling the Network Connections…

Thank you so so much, great job,

Oh yea, one other thing… Do you have any idea what that ICE Listener errors I was getting were for?


More than likely the fact that YaST and NetworkManager were fighting each other to control the network :wink:


Gotcha, figured it was something along those lines…

Again, THANK YOU for all your help,