GNOME network manager applet cant export vpn configuration (nm-applet)


I cant use the option “export” from the VPN settings in the Gnome Network Manager, when I tried to export a popup says “Unknown error”

This happend also in 11.3 and now in 11.4, so it is a nm-applet problema I think…

Is there any other way to export my VPN connections? (because I have really a lot of them :’( with routes)


Weird, I just did this in 11.4 GNOME and it worked fine for me.

I went into the configure VPN screen, highlighted the VPN config I wanted to export, hit ‘export’, selected a file name (it was in my $HOME) and it worked. This was for vpnc though, if that makes a difference.

Maybe it’s some sort of permissions issue? Was the vpn configuration done as root (and you are trying to export it as non-root)? Can you export it as the root user? Are there any errors being generated in $HOME/.xsession-errors or /var/log/NetworkManager when you do the export?

Just some thoughts…

Thanks for your answer katanacb!

Well… I think we found the problem, you told me that you can export VPNC configurations, and you are right… I can export them also!

But the problem seems to be with PPTP VPN connections, could you do me a favor and try to export a PPTP VPN? (its enough if you complete name an ip I think, I tried that with VPNC)

So if you have the same problem we can help the nm-applet developers… :slight_smile:


I looked inside NetworkManager log as you told me, but when the export option gives me the error… the log displays nothing! (I will try to search in xsession as you toldme also)

PD: emmmm… I have accidentally deleted NetworkManager (the log file) :-p do you know if it is a symbolic link or just a file? thanks sorry!

I found that the problem might be in nm-connection-editor when you export VPN PPTP connections, I think that because nm-connection-editor is the applet to edit connections and runs separately of nm-applet.

I tried running it from the terminal window but I cat read any debug error there or in dmesg.

The error remains the same, just after you press the Export button this popup appears…

Cannot export VPN connection
The VPN connection 'CONNNAME' could not be exported to CONNNAME (pptp).conf.

Error: unknown error.

(where CONNNAME is the vpn connection name I assing)

Is there any other way to export the connections?

Thank yous,

OK, I tried to export a PPTP connection and I get the same error as you. If it were me, I’d raise a bug report on this – searching the internet there are several reports of users not able to do this.