Gnome LiveCD installation doesn't include lspci?

I’m trying to get my wireless working on openSUSE 11.1 Gnome installed from the LiveCD and was shocked to find #lspci is not in the system!

Where can I get it from? Is there a package I can get it?

Well if you’re really sure its not just a question of not in your path and su cant find it… Then the package you need is pciutils, search in yast trying a few things(Note wasn’t till I tried file list I got it)

Thanks! I’ll look for it when I get home.

I was just really surprised to find those missing. I looked i the /bin directory and didn’t find it.

I know this may sound dumb, but where is the /sbin directory? I didn’t see it off the /bin directory and I didn’t see it off of / so I’m not sure if I just didn’t see it or if it’s squirreled away somewhere else?

It should be off / sounds strange if it isn’t but can’t really comment don’t use liveCD’s.

Normally essential system binaries are found in sbin it is possible it may end up /usr/sbin but unusual for Suse and certainly on my 11.2 it’s in /sbin/lspci.

Found the /sbin directory in /usr/sbin so thanks for the tip.

Unfortunately, lspci is not in there and I do already have pciutils installed.

Bit of a misunderstanding there is really no reason for Suse not to have /sbin and certainly I don’t know why you don’t have it.

/usr/sbin can be used and is used by other distro’s but for this binary as said on 11.2 m3 factory it is /sbin and I would expect it for 11.1 gnome livecd.

Even checking another distro it should be provided by pciutils so I’m at a lost. Also checking a 11.1 net install it is as expected provided by pciutils and in /sbin

Ok, got things sort-of cleared up.

  1. Yes, there is a /sbin right off of root, don’t know why I didn’t see it before.
  2. I could not run any of those commands until I did
sudo su

and was thus root. Then everything worked fine (well, sort of… wireless still doesn’t work, but that should be another thread)

Thanks for your help.