Gnome-keyring and kwallet under i3 + consequences of mess.

I think these two problems are related, but corelation doesn’t imply causation, so they might not be.

I am guilty of many changes of DEs and distros (Ubuntu (Cinnamon -> unity -> kde) -> OpenSUSE Tumbleweed (KDE -> i3)) and that has left quite a mess of different configs in my home folder, which I have preserved throughout this madness. Everything is mostly ok, but my credentials are fragmented in gnome-keyring, kwallet and possibly other places. I would like to be able to solve this once for all and have ideally one keyring program, that would automatically unlock on login and store everything.

Currently I use i3 and sddm. Until few days ago, whenever a program would want to use gnome-keyring or kwallet, I would get a password popup to unlock it and that was, while not ideal, mostly managable. The respective program stayed unlocked for the rest of the session, which was fine. Some programs couldn’t trigger this dialog (PhpStorm for instance), no idea why, so I opened a program which was able to do so and it was still fine.

A few days ago the gnome-keyring popup stopped appearing at all and at the same time most of my home folder became unavailable from Save-as, Open and similar dialogs. The only two folders available are Downloads and Desktop for some reason. As I said, I have no idea if these problems have anything to do with each other, but they seem related.

Is there any way to fix this?

Thanks a lot for your patience,

I don’t really know how to fix it, because your description isn’t clear.

If you use “GDM” or “lightdm” for login, that should open the Gnome keyring.

If you install pam_kwallet, that might open “kwallet”. But there has been some recent breakage, and I’m not sure of the current status. However, pam_kwallet does not seem to work properly with “lightdm”.

Yes, it would be great if the Gnome folk and the KDE folk could get together with a common keyring plan that both can support.

I use SDDM.
I tried modifying /etc/pam.d/sddm according to and That did nothing.

I’m not sure whether Bug 1133808 is somehow involved in this.

OK. So, I’m dumb. Sorry. VERY dumb. Correlation doesn’t indeed imply causation. The reason for the Open/Save as dialogs seeing only a few folders in my home was accidentaly enabled firejail.

I have pam_kwallet installed AND have added the two lines to /etc/pam.d/sddm according to ArchWiki, but kwallet still doesn’t work. But I think the gnome-keyring might be working, but I don’t know how to check reliably. And sudo is working correctly, so I guess the bug isn’t in effect here.