Gnome/KDE 3 Install

I’m something of a linux newb and I’m having a real hard time with the openSUSE 11 install I just did. The problem is that it defaulted to KDE 4, which I’ve decided I rather hate. I want to use KDE 3.5, but it won’t let me install it. Nor will it let me install Gnome. The package installation seems to get to the point where YAST is downloading libgda,and then it pops up with the “Do you wish to install more packages?” dialog, as if it’s done. It absolutely stops at that point until you press YES or NO, and when you do, it goes back to software management as if you hadn’t installed anything at all.

Can anyone give me some advice on making this work?

Hi Steven,

In the Software Management, are you selecting to view by ‘Patterns’ and then select ‘Gnome desktop’ or ‘KDE desktop’?

First try logging out
At the login screen, bottom left, see what options there are. Make sure kde3 is not there. If not report back here. If it’s there, select it and enter your password.

The popup box you describe is normal at the completion of package install. If a package fails it will ask you to try again, skip…etc

You want to make sure you have
Index of /repositories/KDE:/KDE3/openSUSE_11.0
in your repo list

also: in Yast are you selecting to view by ‘Patterns’ and then select ‘Gnome desktop’ or ‘KDE desktop’?

Also it is better to have the OSS and NON-OSS repos enabled rather than the dvd source which I always disable, saves having to keep putting the dvd in.

Yes. I’ve tried that and I’ve also tried doing it by package groups and by repository. Nothing works.

It’s not there.

Right. Problem is, it’s only about 35% through the install when it does it, and none of the selected packages show up as being installed.

I appreciate the help.

Start again man. Its quicker. Either just choose kde3 or
before the install proper starts, you get a summary screen. You can click on the packages/software section and manually add kde3 and or gnome

Have a look the in /var/log/YaST/xxx logs. Any errors in there?

Just an idea, but maybe going back to basic will help?

Try to reboot into runlevel 3 (‘init 3’ as boot option) and run the text version of YaST to reinstall KDE3 and then GNOME (install them separately).

Might give a better indication of whats going wrong?

That is probably ture! :slight_smile: