Gnome is broken

Hi I had a power failure, now Gnome will not completly start and just hangs almost there.
another member of the family was at the computer and when it restarted and something like TomBoy was flagged as no working and the question was asked if they wanted to delete reference or not , so they said yes now Gnome still will not finish loading. How do i repair from the console prompt?
OpenSuse 11.2 i586 edulife version.

First, I don’t really know what the “edulife version” is, but i suppose it doesn’t differ to much from my version. My first attempt would be to boot into runlevel 3 by typing 3 and “enter” at the grub menu prompt, start yast in text mode and add a new user, then try to boot into that new user account to see if gnome will work there. If it does then surely your problem is in the user settings.

When you say “hang”, do you mean that when it finishes, you are there with

  • your wallpaper
  • your mouse
  • maybe a pop-up notification that you are connected to your wireless router (if it is set to connect automatically)

If so, this is what I have been getting and haven’t figure out how to fix it.

To get around it,

  1. hit Ctrl + Alt + F2 to go to a terminal session
  2. log in as root
  3. type
killall --user <username>

this will kill the user you already logged in as and return you to the login screen

  1. log in like normal, and it usually works fine

I added a second user and found it doesn’t matter who logs in, the first one hangs, then it works fine after killing that user session.

If what you are getting is nothing like what I described… then ignore me! :stuck_out_tongue:

dragonbite:
Funny problem, I run into this every time I login to my 11.2 guest in VirtualBox since a couple of weeks ago, simple solution is to kill the session with rightctrl+backspace one or two times, log in again and all works! Why? It sometimes happens in the host but that’s really rar. I’ve installed todays monsterupdate of Gnome 2.82.0>2.82.2 in both host and VirtualBox guest, but nothing seemed to change!

I’ll have to try that. I thought Cntr+Alt+Backspace was supposed to close the X session, but that doesn’t work. It just gives me a loud “beep”

I’ll try R_Cntr+Backspace and see if that works.

I hope you noticed that " R_Cntr+Backspace" is only in a VirtualBox guest session.
But it’s really a little bit confusing with random errors like this, in VirtualBox I can always boot into runlevel 3, and then start Gnome with the startx command, that never fails, so whats the difference?

Order of initialization?

dragonbite wrote:
> I’ll have to try that. I thought Cntr+Alt+Backspace was supposed to
> close the X session, but that doesn’t work. It just gives me a loud
> “beep”

it is in the release notes of 11.2, you now have to hit backspace
twice…why? to keep folks from doing it accidentally…

it is, after all a rather rude way to shut down X


palladium

dragonbite:

Order of initialization?

Good suggestion, I’ll have a look on that, but for now it’s midnight here in Scandinavia.

Oh well, R_Cntl+Backspace does nothing here.

I did a dmesg before I logged in, and a dmesg after going through the login/root/killall --user/re-login but I haven’t found anything really different as to why the second one worked while hte first one didn’t.