Gnome funny issue

Opensuse 12.1 64 bit

I had kde earlier and wanted to try gnome , so I went ahead and installed it looks nice though but there is an issue, whenever I use any application it does not show up so i need to either go to Activities or switch between apps and it shows up. The Activities menu works perfectly , right now I am typing on gnome and the words I type do not show up realtime hence I change between windows and then it updates the screen , Is that an Nvidia driver issue as I have the latest Nvidia driver and it is working pefrectly in kde

I’m not quite sure what you are describing, so I am partly guessing here.

Gnome 3 seems to want to start each application on a new desktop, instead of having several on the same desktop. This does not happen if you force fallback mode (looks more like Gnome 2).

I think that’s what you are seeing. That’s part of what I don’t like about Gnome 3, and why I prefer fallback mode when I do use it.

I haven’t experienced this behavior. The default for me is to open each new window in the active desktop. Are you sure you didn’t change this tinkering with the settings?

I’m not sure exactly what you’re saying either, but if windows are appearing in the Activities display but not the desktop, maybe they’re opening minimized?

Its the new Gnome. The desktop lags. e.g. if I open firefox and than go to the address bar and type lets say now I will not see any change on the address bar till I jump to Activities and back or switch between any open window. This happens with every app in Gnome.

Why don’t you give us a little information on your system (RAM, CPU, GPU). Do you only have this problem in Firefox, or do you see it in other applications as well? Copy and paste the output from top while this is going on. Please wrap this in CODE tags.


Toshiba L755
i5 2430m
1 GB Nvidia 525m
640 GB HDD
Intel HM65 Chipset.

I reinstalled Gnome and the Nvidia drivers and it working smooth now. Thnx.