GNOME favourite menu and gnome desktop not functioning properly

Sir recently I have bought Toshiba satellite laptop and I have installed opensuse 13.1 on it. Everything is working fine and I am happy with its performance except the following.

In gnome desktop I have added some applications to the favourite menu and the favourite menu is not displaying properly I mean when I launch the desktop the favourite menu is going left bottom of the screen. The second issue is I am unable to switch between applications properly I mean the screen flickers continuously.

I have installed the same OS on another system ie., desktop and found none of the above.

kindly analyze the issue and suggest the solution

Regards,
Rupesh.

Kindly post the details of your graphics card and drivers installed, Rupesh my old friend. :slight_smile:

Thanks for accepting me as your friend.

My graphics card details are
AMD Radeon™ R5 M230. memory amount : 1GB dedicated VRAM. memory type : DDR3 Video RAM

I have installed amd-catalyst-14-4-rev2-Linux.zip which contains fglrx-14.10.1006.1001

I have the same issue on my radeon (Radeon 9600) system.
As I don’t use GNOME anyway I didn’t really bother yet, so I do not know a solution.

I would suspect this is graphics driver related, i.e. the radeon driver in 13.1 might miss a feature that GNOME needs or has a bug that causes this.
But you seem to have fglrx installed. So either that one has the same problem, or it is triggered by something else completely.
Is the fglrx driver actually working/in use?
Please install the package “Mesa-demo-x” and post the output of:

glxinfo | grep render

The flicker issue (I don’t have that here) would sound like a graphics driver problem as well.

Maybe try to remove the fglrx driver again and install it from the semi-official openSUSE repo:
http://en.opensuse.org/SDB:AMD_fglrx

PS: I tried now in recovery mode (which makes GNOME really slow here btw :wink: ), and it had the same problem.
So it’s definitely not specific to the graphics driver.

OTOH, it doesn’t seem to be a general problem either, as you yourself wrote you don’t have it on another system. And I haven’t read of anybody else yet either (I don’t really think that nobody is using GNOME any more… :wink: ).

I haven’t found a solution yet though. Disabling Animations in dconf-editor has no effect regarding this issue (why?).
But it seems to be timing related. It seems to me that the favorites menu doesn’t move to the top quick enough, so GNOME restarts the animation then because it thinks it failed, and this repeats all the time.

Btw, what exactly do you mean with the flickering when switching applications you mentioned as well?
If it’s the display of all applications when you click on “Activities”, then this is in fact the same issue as the favorite menu jumping up/down all the time.
But you should be able to switch applications using e.g. Alt+TAB or click on them on the top bar.

As you specified I have uninstalled amd catalyst software and installed ati driver package from http://en.opensuse.org/SDB:AMD_fglrx.

I am providing the output of the command you specified below

linux-lnx2:~/soft/drivers # glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,
linux-lnx2:~/soft/drivers #

Well, that ati driver package is amd catalyst software.
I just thought that installing the openSUSE package would eliminate any possibilities of failure for the installation.

BUT:

I am providing the output of the command you specified below

linux-lnx2:~/soft/drivers # glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,
linux-lnx2:~/soft/drivers #

You are using intel graphics.
So why do you even try to install AMD/ATI’s fglrx?
That’s useless to you, and you should better remove it again to avoid problems.

So there is no solution to this issue.

I don’t know any yet.
But I still haven’t really investigated more yet. (as I said, I don’t use GNOME anyway)

You might want to file a bug report at http://bugzilla.novell.com/ (same username/password as here).

If I do find a solution, I will tell you. But it doesn’t really have top-priority to me, I have to confess.

On Wed, 20 Aug 2014 07:46:01 GMT, wolfi323
<wolfi323@no-mx.forums.opensuse.org> wrote:

>
>rupeshforu3;2660319 Wrote:
>> As you specified I have uninstalled amd catalyst software and installed
>> ati driver package from http://en.opensuse.org/SDB:AMD_fglrx.
>Well, that ati driver package is amd catalyst software.
>I just thought that installing the openSUSE package would eliminate any
>possibilities of failure for the installation.
>
>BUT:
>> I am providing the output of the command you specified below
>>
>> linux-lnx2:~/soft/drivers # glxinfo | grep render
>> direct rendering: Yes
>> OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
>> GL_NV_conditional_render, GL_NV_depth_clamp,
>> GL_NV_packed_depth_stencil,
>> GL_NV_conditional_render, GL_NV_depth_clamp,
>> GL_NV_light_max_exponent,
>> linux-lnx2:~/soft/drivers #
>You are using intel graphics.
>So why do you even try to install AMD/ATI’s fglrx?
>That’s useless to you, and you should better remove it again to avoid
>problems.

I wouldn’t be too quick on pulling that train out of the station. OP may
have an Intel/AMD hybrid graphics situation similar to intel/nvidia hybrid
setups that need bumblebee. I have yet to see AMD/ATI proprietary drivers
install if they didn’t find compatible hardware.

?-)

Well, I hoped the OP would tell if this is the case (i.e. dual graphics).

But AFAIK, the fglrx driver should take care of such a setup automatically (unlike the nvidia driver).
I do remember having heard of something similar as bumblebee for AMD/ATI cards (or an “extended” bumblebee that supports radeon as well), but even in this case it wouldn’t make sense to have the standard fglrx driver installed.

I do agree though that the OP should clarify which gfx card(s) he has:

/sbin/lspci | egrep "VGA|3D"

Or at least the exact laptop model. Toshiba satellites are available in all possible intel/radeon/nvidia combinations AFAICS.

But this is unrelated to the issue at hand anyway.
I certainly do not have a hybrid system. Just a Radeon 9600 AGP card and not even an onboard graphics chip, and I do experience the same problem with the Activities view in GNOME, even in recovery mode, as already mentioned.

I don’t what’s the problem exactly but yesterday I have searched packages containing intel and fglrx and found two packages which was installed as default during OS installation after that I have uninstalled those and finally I have installed amd catalyst software specified previously.

I am providing the output of the two commands specified by you below.

linux-lnx2:~ # glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: AMD Radeon R5 M230 Series
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image,
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image,

linux-lnx2:~ # /sbin/lspci | egrep “VGA|3D”
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
linux-lnx2:~ #

My laptop details are
Toshiba satellite laptop
Model no : C55-B894
Part no: PSKTCV-01T00JAR

Why did you uninstall default packages. And what were they?? That should not be needed. So the question is really is this a AMD+Intel mix like the NVIDIA + Intel optimus system. ie is this a note/lap book.

As mentioned there is little knowledge here about the AMD+intel hybrid system we do know a bit about NVIDIA+Intel optimus that uses bumblebee.

The packages I have uninstalled are
Xf86-video-intel-32bit
Xf86-video-ati

I have uninstalled the above because previously when I run the command glxinfo | grep render I got wrong output.

I am not taking the issue as serious because everything is working fine except GNOME desktop but I may feel happy if it functions well because it is nice and wonderful than others.

I don’t think you should have removed those.

You shouldn’t uninstall the intel driver.
Install xf86-video-intel again.
You do have an intel graphics chip, and you shouldn’t need to uninstall any of the installed graphics driver as Xorg chooses the right one automatically.

Whatever else you uninstalled you should install again as well.
If I search for intel I find more than two packages though:

# zypper se -s intel
S | Name                   | Typ        | Version       | Arch   | Repository           
--+------------------------+------------+---------------+--------+----------------------
  | intel-SINIT            | Paket      | 2.3-88.1.6    | noarch | openSUSE-13.1-Non-Oss
i | intel-gpu-tools        | Paket      | 1.3-5.1.2     | x86_64 | openSUSE-13.1-1.10   
v | intel-gpu-tools        | Paket      | 1.3-5.1.2     | i586   | openSUSE-13.1-1.10   
i | libdrm_intel1          | Paket      | 2.4.46-3.2.2  | x86_64 | openSUSE-13.1-1.10   
v | libdrm_intel1          | Paket      | 2.4.46-3.2.2  | i586   | openSUSE-13.1-1.10   
i | libdrm_intel1-32bit    | Paket      | 2.4.46-3.2.2  | x86_64 | openSUSE-13.1-1.10   
  | ucode-intel            | Paket      | 20130906-6.2  | x86_64 | openSUSE-13.1-Update 
  | ucode-intel            | Paket      | 20130906-1.1  | x86_64 | openSUSE-13.1-1.10   
  | ucode-intel            | Paket      | 20130906-6.2  | i586   | openSUSE-13.1-Update 
  | ucode-intel            | Paket      | 20130906-1.1  | i586   | openSUSE-13.1-1.10   
  | ucode-intel            | Quellpaket | 20130906-6.2  | noarch | openSUSE-13.1-Update 
i | vaapi-intel-driver     | Paket      | 1.2.0-2.1.1   | x86_64 | openSUSE-13.1-1.10   
v | vaapi-intel-driver     | Paket      | 1.2.0-2.1.1   | i586   | openSUSE-13.1-1.10   
i | xf86-video-intel       | Paket      | 2.99.906-12.1 | x86_64 | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.906-8.1  | x86_64 | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.906-4.1  | x86_64 | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.905-1.1  | x86_64 | openSUSE-13.1-1.10   
v | xf86-video-intel       | Paket      | 2.99.906-12.1 | i586   | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.906-8.1  | i586   | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.906-4.1  | i586   | openSUSE-13.1-Update 
v | xf86-video-intel       | Paket      | 2.99.905-1.1  | i586   | openSUSE-13.1-1.10   
  | xf86-video-intel       | Quellpaket | 2.99.906-12.1 | noarch | openSUSE-13.1-Update 
  | xf86-video-intel       | Quellpaket | 2.99.906-8.1  | noarch | openSUSE-13.1-Update 
  | xf86-video-intel       | Quellpaket | 2.99.906-4.1  | noarch | openSUSE-13.1-Update 
  | xf86-video-intel-32bit | Paket      | 2.99.906-12.1 | x86_64 | openSUSE-13.1-Update 
  | xf86-video-intel-32bit | Paket      | 2.99.906-8.1  | x86_64 | openSUSE-13.1-Update 
  | xf86-video-intel-32bit | Paket      | 2.99.906-4.1  | x86_64 | openSUSE-13.1-Update 
  | xf86-video-intel-32bit | Paket      | 2.99.905-1.1  | x86_64 | openSUSE-13.1-1.10   

Those marked in red are installed on my system.
As I definitely didn’t install them myself (this is a radeon system with an AMD CPU), so they should be part of the default installation.

linux-lnx2:~ # glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: AMD Radeon R5 M230 Series
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image,
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image,

So apparently the fglrx driver is working fine.

linux-lnx2:~ # /sbin/lspci | egrep “VGA|3D”
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
linux-lnx2:~ #

Strange that your AMD card is not listed here, but doesn’t really matter now.

My laptop details are
Toshiba satellite laptop
Model no : C55-B894
Part no: PSKTCV-01T00JAR

Yes. That one is an AMD and intel hybrid graphics system.
Apparently this is called AMD Enduro Technology (as noted here: http://www.toshibamea.com/ComputerProduct/4/Satellite_C55-B894/53015?pageid=4), and it is indeed supported by the Catalyst driver:
AMD Community | AMD

The Linux fglrx/Catalyst driver should support it since version 12.9 beta:

Feature Highlights of the AMD Catalyst 12.9 Beta:

AMD Catalyst Mobility support for AMD Enduro Technology

AMD Catalyst Mobility now includes support for AMD Enduro Technology.

  • AMD Enduro Technology for Notebooks delivers:
  • Long lasting battery life
  • GPU accelerated performance for gaming, video, and compute apps
  • A Seamless and automatic experience

You need the intel driver installed though for that to work.

But I repeat again, this is definitely no graphics driver or graphics card issue.
It seems to be a bug in GNOME.

You shouldn’t need xf86-video-intel-32bit.
But better install xf86-video-ati again, if you ever uninstall fglrx you would need it as it contains the radeon driver.

I have uninstalled the above because previously when I run the command glxinfo | grep render I got wrong output.

What wrong output?

The fglrx driver will not work if the radeon kernel module is loaded. But this cannot be prevented by uninstalling xf86-video-ati, as it is part of the kernel package.
The fglrx installer should take care of preventing that. If the fglrx driver didn’t work, something went wrong with the installation.
If fglrx is installed and working, it should be used automatically.

And it should take care of switching between the intel and the AMD graphics automatically AIUI.

Is there any way of selecting amd graphics card as default instead of Intel.

No idea.
Maybe you can disable the intel chip in your BIOS settings.

But that’s totally unrelated to GNOME’s favorite menu now.
Better open a new thread with an appropriate subject in the appropriate sub-forum (Hardware or Laptop, I would say).

People familiar with AMD/intel hybrid systems might not necessarily read (and reply to) a thread about problems with GNOME.

Can you please try to reply to the following thread

http://forums.opensuse.org/showthread.php/500550-Which-is-the-best-laptop-for-programming-Linux