Gnome evolution and Google online accounts not working

I can not receive any emails, calendars etc from my google accounts.

The error listed in Evolution is

Failed to retrieve credentials from the keyring

and in online accounts it says

 Credentials have expired.


One thing I suspect is not helping is that I always have a Gnome desktop crash right after the initial login (desktop loads and a browser opens) and then I get kicked back to GDM and have to log in again.
I did read about a similar Fedora issue from 2016 that the solution after a Gnome shell crash was to restart the

 /usr/libexec/goa-daemon --replace

but that does not work on opensuse.

OK, this is a weird one but could already be solved.

After my post I decide to see if I can stop the shell crash and hence perhaps solve the problem. I had noticed that the crash was happening when Syncthing was starting and launching the browser at user login. I removed Syncthing from the autostart and now no crash and all my Google services are working. :slight_smile:

Not sure exactly why it worked and now I have to start syncthing after everything else is started and running.