Gnome Desktop: Folder 'Files' changed into 'Dolphin' after routine package update.

Hi All,

After routine online update of packages on 05 Mar 2020, when I opened my desktop ‘Home’ folder, I found that its behavior was like ‘Dolphin’ folder of KDE.
Sometime back, I had installed ‘Dolphin’ for transfer of files between the laptop and my Android phone, through the ‘split screen’ of Dolphin. It has been working fine this far. But since this update, the mentioned phenomenon has occurred on its own.
I would like to have the ‘Files’ back on my Desktop.

Help would be greatly appreciated.

Regards,

RSP2

I’m mostly a KDE person.

In KDE there is a desktop setting for the default file manager. I’m guessing that there is probably a similar setting in Gnome. Perhaps when you tried Dolphin, it had an option “Make Dolphin the default file browser” and you failed to uncheck that box – but I am just guessing there.

Thanks a lot Nrickert,

Shall investigate and come back. In Gnome, I have searched the ‘Settings’ and found no provision to select or change a file browser.
A Gnome expert may know better; so I call upon the Gnome experts to please help.

Regards,

RSP2

Hi
What is the output from;


xdg-mime query default inode/directory

Hi Malcolm,

The result is as follows:

rsp@dell-linux:~> xdg-mime query default inode/directory
org.gnome.Nautilus.desktop
rsp@dell-linux:~>

I am sorry I cannot make anything of this. Kindly enlighten.

Lots of Regards,

RSP2

Hi
That indicates that Nautilus is the default file browser…

If you press the super key and search for Nautilus (Files) does it find it, right click and add back to favorites…

Did you want to show the icons on the Desktop?

Hi Malcolmlewis,

Yes. It is already added to my favorites. It is asking if I wish to remove it from favorites.
I want all my folders on the Desktop to be in Nautilus. I have the Nautilus icon in my bottom panel and I can open my ‘Home’ in Nautilus. But the Desktop ‘Home’ folder appears in Dolphin. I want it to appear in Nautilus.

Thanks & Regards,

RSP2

Hi
Can you post a screenshot of what your seeing…?

Hi Malcolmlewis, Here is the shot of the Desktop. I do not know how to shoot the ‘super key’ display.<br><br> Warm Regards,<br><br>RSP2/home/rsp/Desktop/screenshot.png

Hi Malcolmlewis,

Do I have to reinstall Leap-15.1? Or will this problem go away after removing ‘Dolphin’?

Regards,

RSP2

Hi
Can you post your screen shot to SUSE Paste

They should co-exist…

Hi Malcolmlewis,

Done.

Regards,

RSP2

Hi
It helps to post the link :wink: But I found it from ‘recent’… https://susepaste.org/85023516

So your running ‘Classic’ shell by the looks, so did you delete Dolphin and all back to normal?

Hi Malcolmlewis,

No. I have not deleted Dolphin because you said ‘they can co-exist’. The Desktop is not ‘normal’ yet. The problem persists.
I have got Nautilus in the bottom panel. So, I fire it up whenever I need and then go to the Desktop folders which then open in Nautilus for my working. It is not convenient.
Can you suggest a solution?

Regards,

RSP2

Hi
So if you fire up Tweak Tool and turn off Nautilus control of desktop items what happens?

If you logout and login with the GNOME shell rather than classic, does that look correct?

Hi Malcolmlewis,

I fired up the ‘Tweaks’ and disabled ‘Home’ from ‘Desktop’. The home folder disappeared from the Desktop. After restart, I again went o Tweaks and enabled the home folder. It came back to Desktop but it was still Dolphin.

Actually, I am not using the ‘Classic Shell’ but the ‘Gnome’ Shell with shell extensions.

Awaiting your further guidance.

Regards,

RSP2

Hi
Can you create a test user and login as that test user with gnome-shell and just the defaults, it all works there?

Hi Malcolmlewis,

I did what you said. But it did not help.

Finally, I did the following:

  1. Deleted Dolphin.
  2. Deleted ‘.dolphinrc’ in home folder ‘.config’.
  3. Reinstalled Dolphin.

Things are now working normal.

Thanks for your willing and fast support.

Regards,

RSP2