GNOME crashing from while to while

Title.

From time to time GNOME (or openSUSE itself, not sure…) hangs or crashes, though second one less often. Generally happens when doing any kind of “graphical” activity, such as opening any app, or even just GNOME menu itself, opening Settings, minimizing/maximizing windows, etc.

If hanging it does for a couple of seconds then returns; if crashing it closes session itself, I have then to log in again, finding all previously opened programs closed.
Though once already, a session crashing also took with it kernel itself. I had to electrically force shutdown.

Hardware of your computer

Is this possibly bug 1050256?

If it is, then updates released today are supposed to fix it.

Just did a zypper up right now, rebooted, and a brief hang still occurred. Yes, must be the freaking d**n hardware…

I have, what it seems to be the same problem as you. I’m also running Gnome and this happens quite often, just as you say during more “graphical” activity. It could happen when viewing maps in Firefox. Or right now as I typed this.

It freezes, Gnome seems to be “recovering” itself, and sometimes it can “restart” itself a couple of time in a row, and then log out instead, if it fails to recover.

My computer is quite old. Dell Vostro 1500 with integrated intel graphics (intel 965 gm) and 4 gb of ram. I’ve never had this problem in any earlier opensuse versions, including 42.2, 42.1, 13, 12 etc etc, with Gnome. And 42.2 and 42.3 runs the same version of Gnome (3.20)? So it’s hard to understand what the problem is… I don’t think this is a hardware malfunction. I have run zypper dup and it does not help.

Do you perhaps have Intel 965 as well?

Hi
Perhaps looking at using uxa instead of sna?


cat /var/log/Xorg.0.log |grep SNA

You would need to create a /etc/X11/xorg.conf.d/20-intel.conf file with;


Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "AccelMethod" "uxa"
EndSection

Thanks for the advice. I have not tried it yet…

However, I think that I might have fixed my issue. I’ve been using an extension for Gnome called Caffeine:
https://extensions.gnome.org/extension/517/caffeine/
It’s used for disable “auto suspend”.

If you read the user reviews for the extension it’s seems to be a lot of people that have issues connected to this extension. So I simply removed that extension and it so far it seems to be working alright, and this issue have no returned even after i tried to make the issue reappear, by opening alot of maps, applications and stuff. So think this might be the solution for my problem.

F_style, do you have Caffeine? If you do, try to remove it.

If that “caffeine” thing for Gnome doesn’t come shipped by default from DVD install and one must install it, then no, I never installed it.
Also I never had that coffee icon, so yet another confirmation.

It seems like I was wrong, I was to quick to conclusion… It’s not the Caffeine extension like i first thought… I removed it and it seemed fine for some time but then the problem reappeared again.

Now i believe i fixed my issue. I hope this will help someone…

Even the Opensuse 42.3 installer gives this advice during installation if there are problems related to the gpu. The solution is basically to remove drm-kmp-default.
This will reverse the “graphics stack” from 4.9 to 4.4.

zypper rm drm-kmp-default
(then add a lock in zypper (zypper al drm-kmp-default) to keep it from reinstalling)

I did that when I was having issues (with KDE). And it fixed them.

However, “drm-kmp-default” has since been updated, and the update is supposed to fix the earlier problems. I’m using the updated version, and thus far it has been fine.

It’s good that drm-kmp-default been updated (and it seems to be working for alot of people?). But I don’t think it worked for me… I reinstalled opensuse 42.3 yesterday and it was updated and i still had those issues until I removed “drm-kmp-default” (according to section 1.4, Release Notes | openSUSE Leap 15.3). I think the update might have helped some people, but there still are people (at least one :wink: ) experiencing issues with this package…

Thanks very much for the solution.
I never imagined it would be in the Leap 42.3 release notes.

It worked for me as well doing

zypper rm drm-kmp-default
zypper al drm-kmp-default

Now GUI seemingly doesn’t crash anymore (or almost never) and it’s usable again, including virt-manager.
Package may have been updated during last days, but I think it’s simply not compatible with my hardware…