Gnome compiz trying to get working


I have OpenSuSE 11.0 with a NVIDIA 8600 GTS card working with the NVIDIA drivers setup in TwinView mode.

I can run compiz and everything works except the window borders disappear. I saw one post (I can’t find it now) that says change a setting for metacity but when I did that then compiz wouldn’t start.

I’ve seen posts that say start emerald and others saying it is no longer supported so I am not sure what’s best there but when I tried to start it I got an error.

As a side note (not sure if this is relevent), when I tried “gnome --version” I got these errors:
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option “menuitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option “listviewitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option “progressbarstyle” is not supported and will be ignored.

Any help appreciated.

Check here
Compiz Fusion - openSUSE

Compiz Troubleshooting - openSUSE

I’ve been through those but as it happens after a few days break, tweaks on the server and so on I found one suggest that works which is this: “Try running compiz-decorator --replace”

This is a good start but it’s only a band-aid solution. Do you have any idea on how to track down the root cause or a proper fix?

Maybe there’s a compiz script that’s called that I could modify, any ideas? I did a “grep” through /etc/ for compiz-decorator but nothing came up.


What version of compiz are you using, and what window decorator are you trying to use?

Take Care,


Compiz is 0.8.2-162.1 (x86x64…this is a 64bit computer)

Sorry, how do I figure out which decorator I am trying to use?

Use the fusion-icon to see which decorators are present. I’m not sure how it is in Gnome but with KDE I use emerald as the decorator. In which case your problem can be solved by opening up the CompizConfig Settings Manager (CCSM) and making sure the Window Decoration plugin is active. Then click into it and next to Command erase what’s in there and replace it with:

emerald --replace

Then enable desktop effects and see if that helps.

Take Care,


As pointed out by caf4926 in his links, have you tried;

No window decoration
* rm -rf ~/.config/compiz and restart compiz. This will reset
compiz to default settings.
* To fix your compiz window decorations (titlebars) with an nVidia
graphics card, run sudo nvidia-xconfig --add-argb-glx-visuals -d
24, then restart X.
* Try running compiz-decorator --replace & manually from the shell
or Alt+F2

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2:34, 2 users, load average: 0.07, 0.14, 0.10
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18