GNOME Compiz is buggy, possibly issue with proprietary driver

I’ve been having a couple issues with Compiz:

  1. the window buttons lose their animations (they remain static even when hovered over or clicked on) on nearly all windows; for some reason, applications like Firefox and Abiword don’t have the issue, but all other windows do

  2. window focus is inconsistent. Sometimes clicking on a window raises it to the front, but the titlebar remains greyed out; other times, several windows will display active titlebars despite only one window actually being active

  3. every now and then, programs (like Firefox) stop wanting to draw things to the screen until I minimize and re-open them; e.g. opening a new tab with Ctrl+T shows “new tab” in the titlebar, but nothing changes in the window

I have a hunch that these are partly caused by my using a proprietary AMD driver, but I have a Radeon HD 6850 card that doesn’t work with the open-source driver. I tried switching to it, and I got dropped to a runlevel 3 console when I tried to boot.