Gnome Commander problems (gnome-commander)


My problem is: gnome commander does not start as root. It started before.
Not so long ago i restarted my pc, and i think gnome-commander (as root) did not close. And now it wont start. I started it as: su -> password -> gnome-commander

Where can i check or what command should i run to help u guys diagnose the problem.p

Thanks in advance.

P.S. i tried to run nautilus as root but that did not work either, and gave me these error:
4 errors of this type: (nautilus:8372): Eel-WARNING **: GConf error: …
3 errors of this type: (nautilus:8372): Unique-DBus-WARNING **: Unable to connect to …
Let me know if i should post all of the error mesages.

Any ideas would be apritiated.

You need to use gnomesu;

gnomesu gnome-commander

Thanks for the reply. But i have still the same problem. I start it and it hangs. No error report. Nothing happens. Is there somewhere a log that cathes this error, or maybe some command argument that allows the diagnosion of the problem?

Sorry, was to quick to reply, it worked! The problem was that i left it open in the /proc folder, so it took about 10 minutes to start. Thank you for your help.

What about trying xterm, does that work?

gnomesu xterm

You could also try adding -c after the gnomesu and before the command to run.

You could look at using strace as an indicator;

strace gnomesu gnome-commander

It will produce a lot of output, but it’s only the final output which should indicate what may be happening.

Thank you malclom for your help, next time if it does not start, i will use those commands to figure out the problem. For now it works just fine with: gnomesu gnome-commander.