Gnome aware applications under fvwm

I have been told (by the fvwm author) that the problem I reported in this postl is not an fvwm issue, but is due to the fact that applications like firefox, acroread and openoffice want some part of the gnome configuration running.

Now I just want to use them under fvwm, and having them using for the top menu bar and the menus a legible foreground and background, instead of the white on black I’m currently getting.

I note that under KDE they get a legible black on light gray. I was able to force firefox to do that using a “persona” called “simple fox”, but I’d really like to do the same for acroread and firefox. The good old way they worked under Suse 9.2.

Any simple but detailed solution (like writing a few dot files, or running a simple daemon) ?
I would not learn gnome just to obtain the desirable behaviour under fvwm of which I am a keen user.

I am an fvwm user also, and although hardly an expert in Gnome configuration I had found a reference somewhere to a fix to the same problem. Just create a file .gtkrc-2.0 in your home directory with the following line:

gtk-theme-name = “Traditional”

(Or add this line if the file already exists.) BTW you can have Emacs key bindings if you like in applications like Firefox (text entry boxes like this one) by adding this line to this file:

gtk-key-theme-name = “Emacs”

Probably there’s some way to change the contents of this file, such as these preferences, with one of the Gnome configuration tools, but this works for me. Note it has to be done on a per-user basis (if you have more than one account using the machine).

Hope this helps.

Many thanks.
I created the above file and tested it immediately with openoffice and acroread, and it works !
I haven’t tested it with firefox since I probably have to exit and re-renter it, but I have no doubt it will apply to it too !