GNOME: archive files (tar gz) extracting when double click

Since when this became the “default” for archived files on GNOME?

The default behavior was just opening them with File Roller; now I have to each time right-click, “open with another application” and manually select File Roller.
No clue neither for how to make this the new default…

Excuse me, bump?

I’d expect that your first step probably is to determine what app is actually doing the file extraction, is it still File Roller or something else?
If not obvious, you might see what is happening by having an open console running journalctl…

journalctl -f

Then,
If it’s still Filer Roller, then it’s likely that the command invoking File Roller has been modified or the default behavior has been modified upstream and you have to modify the command to open only.
or
If another app is invoked, then you would probably want to reset it File Roller.

Although I’m not personally deeply knowledgeable about Gnome,
The following article describes how to set the default app for an archive file if you don’t see it as a setting in your GUI management

https://superuser.com/questions/1248426/how-to-set-file-roller-aka-file-manager-as-default-for-all-supported-types-i

TSU