GNOME and Yast

Tonight I decided to upgrade to Open SUSE Tumbleweed. After reinstalling 3 times until I figured out I needed a separate boot partition for Grub 2 to work. I love GNOME, so switching to KDE is not an option. Plain GNOME will not work at all. It would be nice if I could get this working. I don’t really know what GNOME with Wayland is, but it works. The only problem I have with it is that Yast will not work at all. I get the prompt for a password, I enter mine(correctly) and nothing happens. I can’t use anything from yast. This is a big problem for me because the main reason I use Open SUSE is for yast. Any ideas as to why plain GNOME doesn’t work and yast doesn’t work? I cannot test to see of Yast works in plain gnome.

I have grub installed in the root partition, I think you’re mixing efi with grub is that a newer or an older pc, are you installing in legacy mbr mode or in uefi mode?
for yast you need root’s password not yours (unless you checked the box use my password for root)
does su - work with your password?
if not you can change roots password
https://en.opensuse.org/SDB:Recover_root_password

I really don’t use gnome but Wayland is a display server a replacement for X as far as I know openSUSE still uses X but Wayland is available in the oss repo and gnome runs well under both X and Wayland.

I have an older pc, it is a hp compaq 6710b, but runs great. The boot loader is not a problem, it works fine. Root’s password is mine, su works with my password. I need Yast to work

UPDATE: just found out install/remove software doesn’t even work, so I can’t even install software. I just tested and found that yast works in ice wm, yes, my password works.

Hi
Gnome on wayland may still be a bit flaky… log out to GDM, then enter your name and in the selections select gnome-shell and then enter your password, all should be good.

Like I said, GNOME doesn’t work. All I get is a grey screen and a glitchy mouse.

I don’t know if this matters but when I open yast or when software install opens and asks for a password, the little description in the upper left corner next to activities says gnomesu.

This reads like the upgrade to TW did not go so well. What were you using on this machine before TW?

How did you upgrade?
https://en.opensuse.org/openSUSE:Tumbleweed_installation

Maybe you should share your configured repos.

zypper lr -d

Have you tried running Yast in text (ncurses?) mode? Open a terminal and as root, run yast. (to start in graphic mode,it is yast2).

Yast does work in text interface.https://drive.google.com/open?id=0B3hJ9HP4Q5y5Z3dNQ0RJRWk0OUUBut when I try yast2 I get this. https://drive.google.com/file/d/0B3hJ9HP4Q5y5bkVuRElxc3pUc00/view?usp=sharing
About my Repos, here they are. https://drive.google.com/open?id=0B3hJ9HP4Q5y5STI4d2VfR2tMUnc

well yast2-gtk has been abandoned and yast2-qt has issues running on Wayland (kde5 still doesn’t work on Wayland)
openSUSE is not Ubuntu why aren’t you using X, what is the benefit of using Wayland over X, afaik X is the default display server on opensuse how did you get Wayland?

I am not using x because gnome doesn’t work. I believe plain gnome uses x, but plain gnome doesn’t work for some reason, I get a gray screen(the same gray as the background for the login screen) and a mouse that glitches around. The benefit to using wayland over x is that for some reason x doesn’t work and wayland does. I got wayland when I installed. The default display server was x, but at the login screen where you type your password, there is a gear. I clicked it and got presented with the choices Gnome, Gnome on wayland, Icewm, or Icewm session. Plain Gnome doesn’t work so I tried Gnome on wayland. I did not specificity download wayland, it just came with the install. When I run yast from the terminal, without su privliges, it opens fint, but when I su, it spits out:
No protocol specified
QXcbConnection: Could not connect to display :0
/usr/sbin/yast2: line 440: 21195 Aborted (core dumped) $y2ccbin $Y2UI_ARGS “$@”
If yast doesn’t work on wayland, how do I get plain Gnome to work?

Well that’s your real problem Gnome does not seam to work under X, what graphic card and or driver do you have and have installed?
if that is an older nvidia/ati desktop then install the propitiatory drivers (just search the wiki or the forums), if it’s an optimus laptop install bumblebee
gnome needs hardware acceleration to work it’s extremely heavy when used with a software renderer

Yast (in text mode) sees 2 intel 965 gm, but for sum reason it is using i915 drive. I have never installed or found drivers before because everything worked, 13.2 had no problem with x. I do not know how to get or install drivers. Why would x all of a sudden have a problem, and with gnome, not icewm?

so you have a build in intel graphics card?
well TW is TW for a reason it’s the latest and greatest but it has a lot more bugs then the stable releases, why didn’t you go with LEAP.

I went with Tumbleweed because I wanted the latest and greatest. Would this problem persist with leap? Is there a solution to x not working?

would it by chance be a problem with x being too new? could I downgrade x? If so, how?

I’d say this is a bugzilla moment
https://bugzilla.opensuse.org/
tell them your hardware, the TW version (build date) and tell them Gnome works with Wayland but not with X, did you try a different desktop like LXDE with X?

I just submitted the bug. I am trying leap.

Leap works fine, along with yast, but I really wish Tumbleweed would work. I liked the google drive as a network drive. I guess I’ll make due with leap. If anybody has any ideas as to how to make this work pleas post it.