GNOME 40 Bluetooth toggle issue

Been running tumbleweed for about a month. So far so good, but have had Bluetooth issues since day 1. At first I thought it was my hardware but I think it’s gnome.
When I turn Bluetooth off in the top right gnome menu, the icon disappears. When I go into Bluetooth settings, the toggle switch is on even though rfkill states blocked.
This forces me to have to manually turn it on every time by going into bluetoothctl. Not a huge issue, but kind of annoying that the gnome system menu isn’t working.

Anyone else having this issue? I’m using a Dell XPS 15 9500.


I cannot help you much, but what you describe rings a bell since I witnessed something similar in the past.
Now with Gnome 40 everything seems OK here, but occasionally after switching “Airplane mode” on and off the Bluetooth controller doesn’t resume and I need to reboot to be able to switch it on again.
I also saw funny interaction between BT, WiFi and “Airplane mode” (AKA “switch off all radios”) in the past so I think that some HW dependency is at play and Gnome settings might not be able to get a clear picture of what is going on.
Hope that somebody with the same DELL model reads your post and is willing to help.

And, BTW, welcome to the openSUSE Forums!

Today’s snapshot includes updates for bluez and libbluetooth3, maybe worth a shot.

Appears to be working now.

And thank you! Loving Tumbleweed so far. Coming from Mint/Ubuntu systems, I think I made a good choice.