Gnome 3 Wired Network options

I’ve upgraded my opensuse 11.4 to gnome 3 using these instructions openSUSE:GNOME 3.0 - openSUSE

Everything looks good except my eth0 can not be modified. When I use the network config tool from the top right corner the “options” under my Wired connection is greyed out.

I can modify the “options” of any wireless connections.

eth0 does work but I’m unable to modify it from DHCP to a static address. I can set it via Yast by switching to the tradional method but thats a pain.

Has anybody else seen this?

Warning. I have not actually tried this.

Switch to fallback mode. You can do that with “System Settings” → “System Info” → Graphics
and check the “force fallback”. Then logout and log back in.

You should then be able to edit those settings. (I have tried that much, but I didn’t try saving any changes). With luck, you can make the changes you want. Then switch back to Gnome3 mode, and it will probably follow the new settings.

Thanks for the workaround, but thats just as time consuming as using yast to switch to traditional mode.

I need the ability to change between dhcp and static ip on a regular basis…2 or 3 times a day.

Running Gnome 3 for only a few days now but I’m starting to realize alot of the Gnome 3 changes are at the expensive of power users…ie use more than a web browser. Of course Gnome 3 has already failed the “wife” test as I call it.

I think I’ll just end up doing a plain 11.4 install with gnome 2.x

Yes, that was my impression. I only have it installed experimentally, on a different partition. I have no plans to switch my main system to gnome 3.


it works fine with me. i’m using Opensuse 11.4 Gnome3, you may need to tray this — go to terminal and run


and do it from there …