Gnome 3 + Radeon (open) + Mobility 1250 (Samsung R60) = Glitches

I have a big problem…
Gnome 3 (gnome-shell) bar is always corrupted.

Locale is russian.
Restarting the shell (Ctrl-Alt-Backspace-Backspace) does not fix the issue.
Machine had no graphical glitches on w xp.

The issue stretches between OpenSuse 12.3 and Tumbleweed,
All these systems are vanilla, stock, untuned
Upgrade was performed according to OpenSuse Tumbleweed upgrade SDB, process was not interrupted,
all associated stacks are affected: Gnome 3, Kernel 3.7 / 3.11, according xf86-radeon/mesa/libdrm

In Tumbleweed new special effects appeared:
when Gnome just started, the screen is split into four triangles (hypotenuses are faced towards display sides) that quickly flash with default color green.
The “show” disappears within 4 seconds.

Sometimes, invoking glxinfo or glxgears does not work, with response “Error opening display(null)”, after some time or after restarting the shell it works.
The glxinfo looks pretty normal to me, ie Mesa/sgi acceleration (NOT software), version 9.2.2 and GLSL 1.40.

There are no errors in dmesg or Xorg.0.log, these will be attached today.
Xorg config of OpenSuse is extremely weird (but its taken stock and untouched) in /etc/X11/xorg.conf.d/*
I can’t figure out why and what extensions are loaded…

I haven’t tried other Gnome3 distribution (yet; I want OpenSuse) so I retain from opening bug on Mesa/Freedesktop bugtracker, until its clear its not OpenSuse specific.

I have tried increasing GART size by means of “radeon.gart=1024” to grub2 kernel line, I can confirm via dmesg grep that 1GiB gart was loaded.
I have tried using “radeon.dpm=1”, but dmesg indicates no info of power management (pre3.11 or post3.11), I suggest this GPU does not use any kind of reclocking.

dmesg (2.5 Mb, plaintext) Download file - messages.messages

Please help!