Gnome 3 on screen keyboard

I attempting to install openSUSE 11.4 onto a tablet, and I am in need of a on screen keyboard that works on Gnome 3. I can’t seem to find an on screen keyboard in Gnome 3 to use.

Any recommendations or “how to” for setting up an on screen keyboard for Gnome 3.

System Settings -> Universal Access -> Typing Tab, Screen Keyboard ->

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 9 days 15:23, 3 users, load average: 0.80, 0.37, 0.22
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

Thanx for the info.

I think there way be a bug in the current Gnome 3 for 11.4, as no keyboard appears when I select the option to be On.

Any other applications, other than gok, that work for Gnome 3. Can’t figure out to launch the keyboard from weird little window.

OK, looks like the application to install is caribou for an onscreen

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 9 days 16:19, 4 users, load average: 0.22, 0.12, 0.14
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

Installed and attempted to launch caribou.

No luck, I think there may be a bug either with the ATI driver (most likely the culprit) or Gnome 3. The Taskbar at top of screen is also not black, multicoloured bar, with fussy icons. Enabling Desktop Effects crashes the GUI too, that is why I think it is ATI driver problem.

Hardware is Acer Iconia Tab W501P for interest sake.

Maybe need a YaST Software Management pattern called Tablet for all tablet based applications to be listed.

Well today I download the latest development release 12.1 milestone 5.

Well it solved the graphics glitches. Though be warned: DON’T use the open source Radeon driver. MUST add “nomodeset” in the kernel options in the Boot Loader before installation of software packages, else instant crash on starting GUI upon restart. Immediately after installation of 12.1, install the proprietary AMD ATI driver for 12.1, and reboot.

Problem still exists for on screen keyboard not appearing upon selecting to show it. Found out that caribou was not installed, so installed it. Only to discover it fails to start due to “gail” being missing or not initializing correct. Also then installed libgail-gnome, though resulted in no change. Still trying to find out information regarding the error. Perhaps caribou has not been ported to Gnome 3 yet.