Gnome 3 - Lost Desktop - Restore default files?

Hi there

I think I made one tweak too far and as a result have lost my desktop - no top panel, launcher just a blank screen with my desktop background.

I’ve created a new user and everything is fine under that account so I don’t think it is terminal.

Can anybody tell me which files I should delete/replace to restore the desktop back to it’s default settings?

I’ve deleted the .gnome2, .gconf and .gconfd folders but that has not solved the problem.

Any suggestions.

Many thanks

try to delete the ~/.config/dconf folder.

Many thanks for that - it appeared to do the job.


Hi. I have a similar problem which I posted in this forum ( applicatingions are restored to default every restart ). I tried this solution and didn’t seem to work. In addition to losing the desktop, I can’t seem to control it as well. The default applications in the favorites panel is restored every restart. I also can’t change the background image and several other settings. My desktop is not appearing as blank though. I can still use it normally. But I really can’t seem to alter the settings. I also lost the icons at the top panel. Well technically they are just invisible.

Any help would be greatly appreciated.


Sounds like a permissions problem. Check your home directories and make sure all files are owned by you and have full permissions.

You can create a new test user to see if the problem is local or system wide. Note DO NOT log on to a GUI as root!!!

Thanks for the suggestion. However, the same problem persisted in the test user account that I created (I assigned the user standard privileges). I’m really at a lost.

by the way, I was trying to install gtk+extra and lm-sensors when this happened. To install gtk+extra i had to install gtk±2.0 and up plus its dependencies. In one instance I had to an LDCONFIG. I also activated a haldaemon service and a lm-sensors service. Anyway just wanted to share this in case it means something.

This means you changed quite a lot of things that could all be causing the trouble. Can you roll back the changes made and see if things get back to a working situation?

Will uninstalling them be the same as rolling back? Thanks!