Gnome 3 Issues

I’ve just upgraded to Gnome 3 and I’ve had a tinker with it to make it look the way I want it and overall I quite like it, but I have a few issues that I need help with.

  1. The top panel is semi transparent with green and magenta horizontal banding. This could be because the top panel in the old gnome, had been set to be partly transparent prior to the upgrade but I don’t know how to put this right.

  2. Is there a way to only increase the size of the text underneath the icons in the Applications menu screen as it’s way too small?

  3. I’ve still kept Cairo Dock at the bottom of the screen but there is a slight jerkiness/stutter with the parabolic zoom, the motion is just not as smooth as it was with Gnome 2. Could this be because my graphics card is not powerful enough for Gnome 3 (ATI HD 4830), or could it be a fglrx problem?

If anyone can help me out with all this then I’ll be very happy. Thanks.

Both issues can be caused by using the flgrx driver, it doesn’t work with Gnome 3 on any current distro. You need to install the open source one which will remove the visual errors and give you better performance. Edit: There are some reports that flgrx works on intergrated video cards but that it wont work for the higher level stand alones. In my case, a 5870.

I’ve tried to disable the fglrx drivers by following the SDB:ATI troubleshooting instructions:

# rm /etc/modprobe.d/50-fglrx.conf
# rm /etc/X11/xorg.conf
# modprobe radeon
# shutdown -r now

During bootup, the screen goes blank and freezes. Is there anything else that I need to have done?

I’ve managed to boot into the system by adding nomodeset as a kernel boot option, but I’ve still got the top panel and Cairo Dock problems. Can anyone help me with this?

If I boot my Gnome 3 system with “nomodeset”, then I cannot login to gnome 3. It tells me that the system does not have the needed graphic support, and it drops me into fallback mode (which seems to be gnome 2). Maybe it will work for you, but it doesn’t work for me.

Without “nomodeset”, I do get into gnome 3. But that way, the system freezes from time to time. I have to take that freeze risk to try gnome 3.

I have the exact same problem.
Unbelievable in 2011!

If Linux wants to be bigger and better it needs more and better hardware support.

It took me weeks to get it more or less functional on a laptop that costs arround 3400€.

I’ve made some progress. I’ve edited /etc/X11/xorg.conf.d/50-device.conf and uncommented “Driver radeon”, and I’ve also uninstalled fglrx via the Software Manager, and that sorted the top panel and Cairo Dock problems. However, a new issue has now cropped which is much more serious. Whenever I try to open Nautilus, I get kicked straight out onto the Login screen. This does not happen when I log in as root, so I think it might be a configuration setting somewhere that’s causing the problem. Can anyone shed some light on this? Thanks.

I tried running Nautilus from a Shell window and this is the output from it just before I get kicked out of the session

Initializing nautilus-open-terminal extension

(nautilus:9117): GLib GObject WARNING **: specified class size for type 'TrackerTagsView' is smaller than the parent type's 'GtkVBox' class size

(nautilus:9117): GLib-CRITICAL **: g_once_init_leave: assertion 'initialization value !=0' failed
Initializing nautilus-gdu extension

I hope that this will help towards a solution. Thanks.

I’ve finally fixed the Nautilus problem. It was a setting somewhere within the ~/.config folder that was causing all the strife. I just deleted the complete folder, after making a backup, and logged out and back in again which respawned a new .config folder. After copying over all the application settings from the backup one by one, each time logging out and back in again and testing Nautilus, I’ve finally got a working system again which I’m happy with - apart from the remaining issue from my original posting - Does anyone know how to increase the size of the text underneath the Application icons?

Have you install gnome-weak-toll and changed the font settings? Else you may have to look at the gnome-shell.css file.

Thanks Malcolm, I’ll try that.

I’ve played around with some of the settings in the gnome-shell.css file and through a bit of trial and error, managed to increase the size of the text underneath the Application icons. On line 638, I increased font-size from 7.5pt to 11.5pt which made it more readable.

.app-well-app > .overview-icon,
.remove-favorite > .overview-icon,
.search-result-content > .overview-icon {
    border-radius: 4px;
    padding: 3px;
    border: 1px rgba(0,0,0,0);
    font-size: 7.5pt;
    color: white;
    transition-duration: 100;
    text-align: center;

I also decided to decrease the size of the icons.

.icon-grid .overview-icon {
    icon-size: 96px;

On line 579, I changed icon-size from 96px to 72px which made the icons less blurry, though it may be preferable to find out where they are stored and replace them with .svg icons.

have you read this article?
Customizing the GNOME 3 Shell

Thanks for the link Malcolm, I’ve installed the Dark Glass theme that was mentioned in the article and altered the transparency of the top panel so that it blends in nicely with the background. All in all, I think that Gnome 3 with Gnome Shell is a big improvement compared to Gnome 2, and my only niggle is that the Cairo Dock parabolic zoom motion, although improved with the removal of the fglrx drivers, is not as smooth as it was with Gnome 2, but I’ll live with that.

Just solved the same ‘nautilus crash logout’ problem by deleting the file “~/config/dconf/user”
wich was the problem,
Thank’s for that answer :slight_smile:

That’s a better and less time consuming method than mine, which was to delete the whole ~/.config folder. Now I know which file to narrow it down to if I hit the same problem again.