Gnome 3 is in fallback mode

Using the Nvidia driver from the repo on a Geforce 6800gs. In Kde4 all 3d applications seem to be working properly so I don’t know why Gnome 3 is doing that myself. It wasn’t working at all at one point and I am assuming that some update or another got it going. Perhaps a repo switch. Unfortunately I am not sure of what those changes may be. I just know that it does run now but only in fallback.

Any help? What else would you like to know?

Can you try compositor](http://forums.opensuse.org/english/other-forums/development/programming-scripting/464183-compositor-quickly-sets-unsets-compositing-helps-fullscreen-flash-ati.html#post2375655)? - btw it would tell me if it’s working for Gnome3 under openSUSE (it works on ArchLinux and Fedora).
When you type compositor in Gnome3, it toggles between gnome-fallback and gnome-shell (you have to log out/log in). Under Kde or Gnome2, it switchs compositiong on/off immediately. It won’t probably solve your problem. But it might tell you if its a gnome configuration or driver issue. For me, gnome-shell doesn’t work on a dual screen system with nvidia (but kde desktop effects don’t work either on this machine).

I had a similar problem and fixed it by installing the latest nVidia driver from nVidia’s site. Here’s link to the thread on the subject:

11.4 - Cannot install nvidia driver

HTH

O.K. I’ll run compositor, but I need to install it first? I had some repo of yours installed at one point but removed it to clean up a crazy mess in there. You have a link to the repo with compositor in it so I can use Yast to install it?

Yes, compositor is included in conkyconf. Installing conkyconf from my repo will put compositor in /usr/bin.


su -l
zypper ar [noparse]http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_11.4/ PTA[/noparse]
zypper refresh -r PTA
zypper in conkyconf

But if you’re not using conky you should rather remove /etx/xdg/autostart/conky.desktop (Actually, I’m not sure this file is a good idea, I might remove it in the next release).

If you want to disable my repo afterwards - without deinstalling it - just do:

zypper mr -d PTA

But to just use compositor, it seems more reasonable to copy/paste the code posted here compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI) in a file that you would call ‘compositor’ and put in /usr/bin. Then make this file executable with this command:

su -c '/bin/chmod 755 /usr/bin/compositor'

I can imagine that installing the latest nvidia driver might solve the problem.

I want to say thank you for the help and tell you that I found out that somehow Gnome shell wasn’t installed and putting it in fixed it.