Gnome 3- File Manager Handle the Desktop

Has anyone else experienced issues with this option? Using the tweak tool from Malcolm’s repo

If I set it, it works in the current session. But after logout, I can’t login again. At login the desktop appears briefly then closes back to the login screen.

Hi
Which tweak tool (gnome-shell-extension?) is that?

http://thumbnails46.imagebam.com/14142/a1e7d5141413350.jpg](http://www.imagebam.com/image/a1e7d5141413350)

I’ll get the exact detail when I slam packagkit in the abyss

My mistake
Nothing to do with you M
http://thumbnails38.imagebam.com/14142/a96d3d141414329.jpg](http://www.imagebam.com/image/a96d3d141414329)

Hi
Have the same version of gnome-tweak-tool here, which setting are you changing to cause you login issue?

The one here:

It makes it like a traditional desktop with the desktop icons

Just confirmed it for certain in a test account with only that setting changed.

This is .xsession-errors
SUSE Paste

Hi
Hmmm, works fine here, can you open a terminal and run;


tail -f ~/.xsession-errors

When you run the tweak-tool and toggle the option do you see;


INFO    : Adding autostart ~/.config/autostart/nautilus.desktop
Initializing nautilus-gdu extension
Initializing nautilus-open-terminal extension

  1. You want that tail from a console, I can’t login to graphics mode

  2. No

Hi
You can’t login at all? So what files are in ~/.config/autostart/ is there a nautilus.desktop?

I meant once you have a GUI up to toggle the button and watch the log file.

is there a nautilus.desktop
Yes

I did post the .xsession-error log earlier

Saw that, but didn’t see nautilus.desktop in the log, maybe in the .xsession-errors.old, so if you move that desktop file out of the directory, can you login?

Move the nautilus.desktop - but couldn’t login

There was no .xsession-errors.old
The next login created a new file, here is the content:

SUSE Paste

Hi
Well all that toggle does is copy the nautilus.desktop to ~/.config/autostart/ and run it which is the command ‘nautilus -n’, then if you switch it off, kills the nautilus process and removes the desktop file…

Sounds like something is corrupted somewhere… so even a test user can’t login?

I created a test user just for the purpose of confirming this issue. Only making that change from the defaults.
I’m back in KDE for now. But I need to look at Gnome 3 for when 12.1 is released.
I do actually like it, it’s very slick looking. But ATM I just can’t work quickly enough with it, but that’s partly a learning curve.

Don’t fret over this. But I’ll work on it in the morning.

I think I may have had a related, though not identical problem. I could only open the file manage twice, then it’d crash. First time, normal opening. Second time, it’d sort of flicker then open. Third time, Gnome 3 would crash with the “something unexpected happened” message and I’d have to restart. I eventually resolved the issue by turning OFF “let file manager handle desktop”, and then (based on advice in another forum) in the Preferences for the file manager, turned off “show thumbnails” and “count number of items in folder”. This stopped the crashing, though I’ve no idea which one(s) of these three changes had the beneficial effect. From what I’ve been able to gather, either a corrupted file on the desktop or a corrupted Nautilus.desktop can cause the UI to crash. I’m guessing that if you have the file manager linked to the desktop via this “manage…” setting, opening the file manager can have the same effect. All speculation, of course, but if you can get to these settings and change them somehow from the console, it might be worth seeing if you can turn them off.

If you create a new user, just for testing. Login with it and see if the problem remains there. This will establish if it’s user level or deeper.

Yes, I just tried your suggestion, and the file manager issue remained, even with a different user. Interestingly, when I then logged out, and went back to my own login, the file-manager-induced crash problem was once again present - even though “manage desktop” was set to off. However, after turning off everything on the “desktop” tab, such as “show home folder on desktop” the file manager began behaving normally again. This all seems to imply that the errant behavior has something to do with having the “home” or “trash” icons enabled on the desktop, whether or not their actual display is enabled with the “allow file manager…” setting (since having the latter set to “off” turns off all desktop icons, even if the actual switches for them are enabled).

With this feature on I have only noticed slow down issues in launching nautilus but only in earlier versions of openSUSE than the current 12.3
For me it all works fine, though I don’t actually use this feature. I have tested it.