Gnome 3 fails me – general problem solving

Gnome 3 raises so many questions, but leaves no answers, and this makes it frustrating: I’ve just managed to fix Gnome 3 on openSUSE 11.4 so it just works. However, the WiFi network still does not work, as it cannot generally enable the WiFi. But I cannot resume to fix it—which also makes it impossible to find the cause—because a full-screen game crashed, leaving it in a small screen resolution. When I wanted to change the display resolution back, Gnome just crashed, and crashes every time when I log in.

I know that I can see error messages in ~/.xsession-error file, but I don’t know how to read it (How to interpret the messages that I read). Where can I learn about the flow of the application Gnome 3 starts from log in till it crashes?

Luckily I can connect through Ethernet, and the network works in the terminals (ctrl-alt-1, …) but I’m working with applications that need graphical environment.

Also when does Gnome 3 becomes stable? (Fool-proof stable!)
Where is Gnome 3.2 available?

How did you install GNOME 3.0? I’ve been running Gnome 3.0 for a while
now without issues as in stable. I installed Gnome 3.2 on the ASUS
1000HE netbook as well (see screenshots in the screenshot forum) some
funnies with power management, but aside from that useable.

Sounds like it’s an issue with the X11 driver, not the DE, have you
tried switching to ice-wm or twm to see how that goes, what about
starting in fallback mode for G3?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 6 days 1:06, 3 users, load average: 0.11, 0.20, 0.22
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

I’ve installed it with one-click install. I’ve also tried to install several packages (can’t recall them) but those worked since then.

I can use other window managers, though currently it is suspended, but I would use WindowManager, as I did for such case before. But there is a fallback mode? How can I achive it?

Open a console session or login from a VT and run;

gsettings set org.gnome.desktop.session session-name gnome-fallback

Also check;

zypper in gnome-shell metatheme-adwaita-common

  1. Check if you installed the extension called “gnome-shell-extension-xrandr-indicator” and delete it; i causes problems with X
  2. Check if you have libgnomekbd installed
  3. Check if you have mutter and gnome-menus-branding-openSUSE

Why the checks? Well, because when i did installed Gnome 3 using the tutorial from the wiki libgnomekbd was not upgraded to 3.0.2 and the extension got installed. So check and double check; re-read openSUSE:GNOME 3.0 - openSUSE

The gnome-fallback works. Whew!
gnome-shell, metatheme-adwatia-common, mutter and gnome-menus-branding-openSUSE is installed.
the xrandr indicator was installed previously, but I figured out, that it is causing trouble (Actually the “Oh no!” screen.)
However, I did not find the libgnomekdb, but not even as an option. But I doubt that it is caused by this, as it were working before, and did not install or uninstall packages before this happened.

But now what, now that I have Gnome up and running?
This means, I cannot use the new style?

Ps.: Now I remember, that I’ve connected an external monitor to this laptop, and played with the display settings a little, but since then, I’ve reinstalled openSUSE (more than twice) as a short solution.

So what graphics do you have?

/usr/sbin/hwinfo --gfxcard

It’s an Intel graphics card, I presume one with Intel Core i3.

Here is the output:

09: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.318]
  Unique ID: _Znp.J5+t5CwGL99
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Arrandale Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0046 "Arrandale Integrated Graphics Controller"
  SubVendor: pci 0x104d "Sony Corporation"
  SubDevice: pci 0x9071 
  Revision: 0x02
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf0000000-0xf03fffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0xe080-0xe087 (rw)
  IRQ: 41 (3098 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00000046sv0000104Dsd00009071bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Btw.: This is a Sony Vaio VPCEB1J8E

You haven’t got nomodeset set?

cat /proc/cmdline

Is the xorg conf file in /etc/X11/xorg.d using the intel driver?


In my /etx/X11/xorg.conf.d directory, (I don’t have /etc/X11/xorg.d) I found no trace or sign of an Intel driver configured, or referenced. The 50-monitor.conf and the 50-device.conf files are practically empty (regards to drivers), 50-screen.conf refers to the monitor defined in the monitor conf file.

If you look through the /var/log/Xorg.0.log any hints there, you might
also look through the ‘old’ ones when the system was not set to
fallback mode.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 6 days 4:42, 3 users, load average: 0.28, 0.29, 0.24
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

I’m not sure what am I supposed to look for there, but I also see that the Intel driver, and Intel graphics chipsets listed by the VESA modul, if I understand it right. It uses VT 8, (why, is beyond me) Also there is a fallback warning message (I suppose WW means that). But then it seems that if something called “intel” is reporting screen resolution. And afterward it unloads everything but “intel”, so I presume it is used. I try to attach the log files (I find it too long to paste it here), as I cannot see anything suspicious there my self.


Definitely the Intel driver is in use. I note in your 1st post you state you are using openSUSE-11.4. But I also note the kernel according to that log file is kernel-3.0.4-43-desktop. Where does this kernel version come from ? What (if any) graphics packages have you changed ? Having a non-standard setup makes support very difficult if one has not tried the same non-standard apps themselves.

Are you using Tumbleweed ? Note we have a forum area for Tumbleweed posts: Tumbleweed

I’ve added the Tumbleweed repo as a last try before solving the problem, and also upgraded the kernel from there, after I read somewhere, that certain kernel version can cause trouble with NetworkManager. (They downgraded, I rather upgraded it.) But that is not why I added the repository.