Gnome 3 fail whale "Oops, something..." after update from 11.4 to 12.1 [some progress]

I’ve been trying to fix this for a couple of days now, and I feel I’ve made some progress, but not enough…so maybe there’s somebody out there who can help me.

I did an upgrade from 11.4 to 12.1 and implicitly got Gnome 3. Except that…gnome 3 doesn’t want to play nice (yet).

When logging in from gdm, I get a pause (around 10 seconds). Then, for a couple of seconds, the “Oh no…” fail whale message. Then the gdm background comes up again, and after another 10 seconds the fail whale reappears. Except that… I can now click the fail whale, close it with ALT+F4 and use the system as if nothing wrong is going on (gnome-shell, extensions, applications - everything working nicely).

So, advice no. 1 for anybody experiencing this - try closing the fail whale and see how it goes…

Ok, so I can use my system. However, the issue is far from being “acceptable” so I have set up to fix it.
Here is my .xsession-errors file:


gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/tmp/keyring-qo4RXx
GNOME_KEYRING_CONTROL=/tmp/keyring-qo4RXx
SSH_AUTH_SOCK=/tmp/keyring-qo4RXx/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-qo4RXx
SSH_AUTH_SOCK=/tmp/keyring-qo4RXx/ssh
GPG_AGENT_INFO=/tmp/keyring-qo4RXx/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-qo4RXx
SSH_AUTH_SOCK=/tmp/keyring-qo4RXx/ssh
GPG_AGENT_INFO=/tmp/keyring-qo4RXx/gpg:0:1
**gnome-session[2606]: WARNING: Application 'gnome-settings-daemon.desktop' failed to register before timeout**
** Message: applet now removed from the notification area

** (gsynaptics-init:2765): WARNING **: Using synclient
Initializing tracker-store...
Initializing tracker-miner-fs...
Tracker-Message: Setting up monitor for changes to config file:'/home/calucian/.config/tracker/tracker-store.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/calucian/.config/tracker/tracker-miner-fs.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/calucian/.config/tracker/tracker-store.cfg'
Starting log:
  File:'/home/calucian/.local/share/tracker/tracker-miner-fs.log'
Starting log:
  File:'/home/calucian/.local/share/tracker/tracker-store.log'
Failed to play sound: File or data not found
Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension
(nautilus:2759): Tracker-DEBUG: Initializing tracker-tags extension

lpstat: Connection refused
      JS LOG: GNOME Shell started at Sun Nov 20 2011 22:08:42 GMT+0000 (GMT)

The only interesting bit is the one with the gnome-settings-daemon.desktop refusing to register.

So, I’ve set up to see what happens at boot time, and did a bootchartd installation & run. So, now I have this pretty picture of my boot process going on (including the gdm login).

Image attached

So the interesting thing to see there is in the second half of the image, after gdm & Xorg start.

First, gdm starts gdm-session-worker, which in turn starts gnome-session, gnome-settings-daemon and gnome-session-c(something).
gnome-session proceeds to start gnome-shell. However (my interpretation of things) up to this point no dbus-launch was done,
so all those fail miserably (leading to the timeout in .xsession-errors and to the display of the fail whale).

Next, gdm-session-worker is respawn but this time loads bash, nvidia-settings and does a propper dbus-launch of gnome-settings-daemon and gnome-shell - this is the second part that I observe, when everything loads - of course, the fail whale is still there from the previous failures, but I can now close it and work (although feeling kind of dirty after all this nonsense).

This is where I stop knowing what to do. I have poked around and tried adding dbus-launch in /etc/X11/xinit/xinit.rc (when starting the WINDOWMANAGER) but this has so far not modified anything. And I am also aware that gnome-session should spawn its own dbus if it finds none. I can confirm that dbus-daemon starts properly (at least on my system) and that other dbus-based apps work normally (for example the NetworkManager in the Gnome 3 bar).

So…If anybody knows any better and can help me fix this…

Cheers

A small update on this…

The gnome-session and gnome-shell load normally (no fail whale) if I don’t have any network connectivity during the boot process… (no wired or wireless networks accessible). It still looks to me as an timing issue. I’ve done the bootchartd run again in this case (no networks) and the startup does look a bit different. gnome-session-daemon and gnome-shell still fail once (and are then respawn) but they do so much quicker, and I don’t get the timeout error in .xsession-errors anymore.

I’m attaching the new bootchart image here

By the way, the booting process in 12.1 doesn’t look that optimized to me. It doesn’t say everyting, I agree…but 19 s total cpu time in a boot of (more or less) 110 s means a lot of waiting on IO / dependencies / whatnot. Or is it that I’m not reading the graphs correctly?

On Sun, 20 Nov 2011 22:56:02 +0000, luciancarata wrote:

> Ok, so I can use my system. However, the issue is far from being
> “acceptable” so I have set up to fix it.

A trick that I read somewhere (not sure where) was to make sure you’ve
configured an avatar in the user config. I want to say “especially if
you’re using the alternate menu extension”, but I may be misremembering
the correlation there.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

It looks well attached indeed. Click on that link! (maybe log out from that site first and clean your cookies).

Well…embarrassing. Sorry about that, I was under the impression that I did log out first.
Here are the links:

Original (with network available)
No Network

Oh, btw… I do have an avatar set up, so I don’t think the issue is from there…