Gnome 3/Cinnamon doens't lock screen after timeout?

Last week my screen locked as I had it set, after 3 minutes of inactivity. Now the screen goes black but the requirement to enter a password doesn’t happen. Moving the mouse or keyboard the screen comes back.

This started after a round of updates I installed late last week.

Anyone know where I could even start to look? My settings to lock the screen are ON.

So apparently it’s related to xscreensaver… which I believe I saw updates for KDE come through last week.

[SOLVED] gnome-screensaver won’t work](

I haven’t tried what the poster suggested yet.

No, gnome-screensaver doesn’t need xscreenssaver to be installed . I am using a pure “GNOME” system.
As suggested in the link you can try re-installing gnome-screensaver using YaST.

I realize xscreensaver isn’t required, but apparently there is a conflict of some sort somewhere for that solution to work for the poster in that link. Which is why i’m suspicious of the KDE updates last week. I uninstalled both and only reinstalled gnome-screensaver, still have the same issue. The screen doesn’t lock on the timeout. Not much info anywhere. I can use gnome-screensaver commands but gnome-screensaver-command -l or -a don’t work.

to bump this…

and say…

i can open terminal and run gnome-screensaver… then the screen locks as long as i don’t close the terminal window. I checked the Gnome Editor and it is listed to run on start-up but isn’t.

Is there another way i can set to this to start? Would really like to have the ability to lock my screen again.