glxgears, fgl_glxgears run, but no "picture" or "stagnant" picture

Hello,
recently purchased all new equipment (home built pc):
motherboard and processor - AMD FX6100, Motherboard is GA-78LMT-S2P Socket AM3+ 760G mATX AMD
16 gig memory,
Radeon HD 6450 video.

Motherboard has the “Onboard Graphic Chipset ATI Radeon 3000” Onboard video is disabled in BIOS.

Operating system OpenSuSE 12.2 (up to date) I have dual screens setup, downloaded and installed Catalyst 13.1 from ****Index of /mirror/amd-fglrx/openSUSE_12.2, it installed no problems. Have also tried the proprietary drivers direct from AMD, but if I understand correctly, these are the same as the previous link.

If I run fglrxinfo:
display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: AMD Radeon HD 6450 OpenGL version string: 4.2.12002
Compatibility Profile Context 9.012

Issue that I am having: when testing with fgl_glxgears it does popup the gearbox window, but I get no image unless I click on the title bar. Then it immediately stops, until I click again. The image will stay “static” unless I “grab” the window title bar and keep dragging it around the screen. This is the only way to keep the gears moving (visually), once I stop the mouse, the gears “stop”, I say visually because the terminal keeps spitting out fps. This also happens with any games that I try. Videos work with no problems, so not sure what may be going on. Tried the same with glxgears, exactly the same results.

I have checked hi & lo across the net, even through these forums and have found many other issues, but none that reflect what I have occurring.

Any help is appreciated,

Thanks, Anthony

On Sat, 26 Jan 2013 05:16:01 +0000, almcneill wrote:

> Operating system OpenSuSE 12.2 (up to date) I have dual screens setup,
> downloaded and installed Catalyst 13.1 from

Did you install the “legacy” or the one that’s not flagged as legacy?

You need the “legacy” version - anything that’s a 4000 series or below
uses that.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Jim,

No I did not install the legacy drivers. I researched it first and my card “Radeon HD 6450” uses the non legacy drivers. Just to add to it, I did try the “default” radeon driver (in xorg device section) provided by opensuse, and it did not have these problems. But I also noticed that using that driver produced lower fps than the amd driver produces. I may be incorrect, but from what I have read, the radeon driver does not have the “power” of the amd driver.

I had that for awhile on my system (HD6800), but I don’t use the ‘regular’ kernel, I always thought that was the root cause of the problem. What kernel are you using? I am currently on 3.6.8 and don’t have the issue an longer. It also works with kernel 3.7.x but since I can’t get my TV card working with that kernel I stay with 3.6.8.You could also try to install the AMD driver via Sebastian Sieberts script.
Here is the link to the installations instructions, it is all in German but still easy to follow. I also suggest you install ATIUPGRADE (just do a search in the forum) as well.

https://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber#Installation_via_makerpm-amd-Skript

Well that is encouraging news that I am not the only person to have this problem. I will do a search for the atiupgrade, I think I already found the forum page with it.

When you say ‘regular’ kernel, what exactly do you mean by that, kernel-default (the standard kernel)? I ask because by default, the kernel installed for me was the kernel-desktop.

Kernel 3.6.8, could you let me know where you found the repository for this? My current version is 3.4.11, and I have run the check for updates and it states that it is up to date.

Thank you for the pointers, your experience with this has given me hope.

I think your kernel should be ok. I use one from this repository, but if you don’t know exactly what you are doing the be careful and make a full system backup first, so you can go back.
Index of /repositories/Kernel:/stable/standard

I still suggest, you try first to install the driver with Sebastiann Sieberts script.

Tried the scripts, I believe I must have done something wrong, it did not seem to actually do anything. It did download some extra files, but then nothing at all after that. I am still reading about it. I do understand the need for a full system backup, but in this case I am not overly concerned for 2 reasons:

1 - I already had one prior to my last motherboard failing on me (this has bit me in the past).

2 - This is all brand new install, so totally up for experimentation.

With that being said, any off the wall suggestions are welcome, as if I have to start from scratch again, it will be a short step backwards.

Thanks again for your help. I will keep plugging away at it. If I somehow manage to get it to work, I will make sure to record all my steps here for others that may be in need. In the meantime, any and all suggestions are welcome.

So finally got smart about it and “translated” the page, funny how that works (sometimes my brain just does not engage). Anyway, followed the steps, ran the script, followed the final step (rpm install):

zypper install fglrx64_xpic_SUSE122-9.012-1.x86_64.rpm
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Nothing to do.

So apparently it sees everything being current. Am now going to try to update my kernel to 3.7. Hopefully will be back shortly to update, otherwise might be an hour or two.

Ok,

So have updated my system, now using kernel 3.7.4. Re-installed the amd drivers (using the script), all went well with that. After running glxinfo I get:

glxinfo
name of display: :0
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66 ()
Serial number of failed request: 13
Current serial number in output stream: 1

Just for laughs, I click on the “My Computer” icon on the opensuse desktop and for Display info it states:
Vendor: ATI Technologies Inc
Model: (This shows nothing, prior to this it showed ATI)
2D driver: fglrx

Will wait for awhile and see if anyone else might have some thoughts, if not, I think I might go back to my old nvidia card in the meantime.

Not sure if this has anything to do with all that is going on in previous posts or not, but I happened to notice something during the boot:

SP5100 TCO timer: mmio address 0xfec000f0 already in use
I had noticed this on a previous boot as well, but as it did not effect the startup process in anyway, I did not pay much attention to it. But I did a google search for this, and from what I have been seeing, it has caused others not to be able to even boot their kernel (this did not happen to me). Some of the posts that I scanned through mentioned corruption in video, so this is what is making me think maybe something to do with it.

I do not know enough about kernel/boot messages to determine if this might actually be my culprit or not, so if anyone out there can enlighten me, it would be much appreciated.

You only have to do this ( no need for zypper anything):

  1. start a terminal (I forgot the English word, maybe I am wrong about the word terminal), you have to become root: su

  2. Download the script (you are still in the terminal): wget http://www.sebastian-siebert.de/downloads/makerpm-amd-13.1.sh

  3. Download the checksum (you are still in the terminal): wget http://www.sebastian-siebert.de/downloads/makerpm-amd-13.1.sh.sha1

  4. Check the script(you are still in the terminal) : sha1sum -c makerpm-amd-13.1.sh.sha1

You should see this output or your download went wrong: makerpm-amd-13.1.sh: OK

  1. Change the rights of the script and make it executable(you are still in the terminal): chown root:root makerpm-amd-13.1.sh && chmod 744 makerpm-amd-13.1.sh

  2. Execute the script with the -i (you are still in the terminal). The rpm package will be installed automatically.(no need for zypper) ./makerpm-amd-13.1.sh -i

**Now, you need to reboot your system

**

  1. If something went wrong, you can de-install the driver with the -u argument, open a terminal become root and then: ./makerpm-amd-13.1.sh -u

Just to make it clear, this is not from me. I only translated Sebastians instructions to help you out. You can actually post your questions in English on his webpage and he will answer help aou.

On Sat, 26 Jan 2013 07:36:01 +0000, almcneill wrote:

> No I did not install the legacy drivers. I researched it first and my
> card “Radeon HD 6450” uses the non legacy drivers.

Shame on me for not reading closely enough - I saw the onboard chipset
was a Radeon 3000 series, and lept to the conclusion that that was what
you were using, not that you had disabled that for the 6450.

I’ve got a machine with an onboard 6450LE controller, and I had no luck
at all getting that to work with the Catalyst drivers. The one I have
just didn’t have the oomph to do what I wanted (I don’t know about the
6450, but the 6450LE uses shared memory for video memory, so it takes
memory from the system memory to use for video memory - and that’s not
very efficient and the driver didn’t do very well with it).

I ultimately used the radeon driver instead until I got a new machine,
and the old machine is acting as a lower-end server now.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Thanks, yeah I already translated it earlier today after the thought of doing that actually hit me. The install script did fine, but it only brought me back to square one. Maybe I will send him an inquiry about my problems, maybe he has already encountered/corrected this.

Jim,

How did the radeon driver perform for you? I have thought about getting a better card, but I already spent the money on this one, it has 1 gig ddr 5 on board. Maybe I will start saving for another, maybe 7xxx line.

Just very frustrating running glxgears, terminal showing frame rates between 3000 and 3800, but the images just don’t move! Makes me believe that the card is actually powerful.

So, I wanted to post something as an add to the thread/troubleshooting. On the AMD web site (where you download the driver), they of course give some instructions (after selecting options for the driver). The very last couple of lines state something rather interesting:

The drivers above support English only.
The display driver requires POSIX shared memory to be enabled on the system.
Kernal Sources package is no longer required if Kernel Header package is installed.
32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

I find the last line very interesting, it does not actually say what packages, but maybe there is something that is not being installed? Any thoughts on this?

On Sun, 27 Jan 2013 02:36:01 +0000, almcneill wrote:

> How did the radeon driver perform for you? I have thought about getting
> a better card, but I already spent the money on this one, it has 1 gig
> ddr 5 on board. Maybe I will start saving for another, maybe 7xxx line.
>
> Just very frustrating running glxgears, terminal showing frame rates
> between 3000 and 3800, but the images just don’t move! Makes me believe
> that the card is actually powerful.

The radeon driver performed well enough for me to use the system for
business apps (LibreOffice, browser, e-mail), but I couldn’t use it for
playing games that required acceleration.

That said, it sounds like your card is better than the LE version in that
it has its own memory on board, so your experience will probably be
different than mine with that model card.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Well just wanted to provide an update: I tried a couple of older revs of the amd catalyst drivers, yet the problem still remains. Running out of ideas.

Ok, so now my mind is blown. I have it working properly now, something so simple and obvious. As stated in a previous post, this was a new install. I was playing around with my linux box, getting all my settings back to where I like them. Well one of those settings was the Desktop Effects located under Configure Desktop. I clicked on the Advanced tab and noticed that the Composting type was set to XRender, I changed it to OpenGL, and when I did, something rang a bell in my head from all the researching I had been doing.

I applied the settings, opened up konsole, typed in glxgears AND THE GEARS WERE SPINNING!!! So I tried the same with fgl_glxgears it ALSO WORKED!!! And I cannot complain, glxgears is averaging 2500 fps, fgl_glxgears is averaging 650 fps.

Compared to the old nvidia card I had in the old machine, it is amazing, the old card under glxgears would barley hit 100 fps.

Jim and swannema, thank you both for your input. Without getting responses, I probably had given up long ago.

I truly hope this simple solution does provide help for others that may be having problems.

Now, is there a way for me to show this thread as “solved”?

On Sun, 27 Jan 2013 06:46:01 +0000, almcneill wrote:

> Jim and swannema, thank you both for your input. Without getting
> responses, I probably had given up long ago.
>
> I truly hope this simple solution does provide help for others that may
> be having problems.
>
> Now, is there a way for me to show this thread as “solved”?

Awesome to hear that you got it resolved. We don’t typically tag threads
as “solved”, but I’ve added “[Solved]” to the subject line of this post.

Thanks for reporting back!

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Massive thanks, almcneill!

Works for me too (OpenSuse 12.2, fglrx 9.012-1, AMD “Llano” A6-3670 with integrated Radeon HD 6530D).

You are describing KDE System Settings:

I haven’t been able to use Celestia for over a year … due to a setting! My mind is blown too.:shame: