Glabels 3.4.0 missing GNU Barcode Support

Can someone assist in Compiling the source with the right settings? I tried and failed.
This problem exists since 13.2. Kubuntu still works.

|[Will Jordan (will-jordan)]( wrote on 2014-02-26:|#3](|

[FONT=monospace]The EAN8/Code128 barcodes that were originally in glabels and are not in this build were provided by GNU Barcode. (Zint support was added in a recent version, but this barcode library does not yet have an official Ubuntu package.)
Something seems to be affecting the amd64 build environment causing the autoconf line "AC_CHECK_LIB(barcode, Barcode_Create, ...]" to return false even though the "barcode" package seems to be installed correctly. Looking at the logs it seems to affect recent AMD64 but not some other builds (e.g. i386 build logs show GNU barcode support is included).
I just built glabels from source off github and the barcode support was included as expected.


Old Thread with bug:

Have you tried to run a pre-compiled version of glabels?
The following page includes a generic install and lists its requirements.

Although the glabels version is 1 year old, if you inspect its github project no changes have been submitted within the last 10 months so I doubt compiling will help


Hmmm, not sure why it never got fixed… here is a test build for 42.3 (and it will publish for you to test).

glabels probably needs to move to graphics anyway…

Thank you for your help, but obs is telling me:

Package “glabels” not found in project “home:malcolmlewis:branches:GNOME:Apps”

Yes, branches disappear when packages are accepted back to the development project, so check GNOME:Apps, it made it automagically to Tumbleweed now, but needs maintenance update for 43.3 (after release).

Ok, thank you, I upreaded to 42.3 and installed it from tumbleweed repo.
It is working.