git cvsimport using cvsps

Trying to use git-cvsimport, but it is in conflict with the cvsps.

Running Opensuse 12.3
git version
cvsps version 3.8
cvs version 1.12.12

The orignal cvs project is under /home/username/workspace/myApp. I’m trying to convert it over to git under /home/username/workspace2/myApp. Chose different location because I wanted to test the convertion/cvsimport first.

First exporting cvsroot

username@machine:~/workspace/myApp> export

username@machine:~/workspace/myApp> git cvsimport -d $CVSROOT -C /home/username/workspace2/myApp -r cvs -k myApp
Initialized empty Git repository in /home/username/workspace2/myApp/.git/

bad usage: invalid argument --norc

username@machine:~/workspace/myApp> git cvsimport -C /home/username/workspace2/ myApp
Initialized empty Git repository in /home/username/workspace2/.git/

bad usage: invalid argument --norc

Checking the manual pages for cvsps the argument --norc does not exist.
Trying to check online for cvsps cvsps(1): create patchset info from CVS - Linux man page

when invoking cvs, ignore the .cvsrc file

I do noty know anything about cvsps, nor do I see your real question.

But it seems to me that you use an option for a command where that command says it does not understand it. And where teh man page on the sytem confirms this.

Then you found another man page on the internet which has that option.

My conclusion: different versions op the tool. Try to compare them.

Am <guessing>
That a cvsrc file is missing from your current cvs, so the --norc is automatically invoked.

Maybe create a cvsrc file, even if it’s empty?


Back from the holidays. Unable to respond before now.

Well the question was implied. Anyway. Seems git cvsimport is calling cvsps with an illegal parameter. I do not control how git-cvsimport call cvsps.
Wonder if this could be solved by using a different version of cvsps. I’m not sure which version of cvsps that git-cvsimport requires. If git-cvsimport requires a different version of cvsps this should be provided with opensuse instead.
Or is there any options I can supply to git-cvsimport to avoid this problem?

Tried adding an empty .cvsrc file. It did not have any effect.