gimp has apparently been broken by an update

I update daily, but do not use gimp every day. I am assuming that an update from somewhere broke gimp. gimp will now not open and leaves no clue as to why. So far, all I have done was to rename the .gimp folder within my home folder, with no joy.
When I run the command from a terminal, the cursor drops 1 line and then does nothing. No errors. No messages. Cursor does not flash. I have also tried using the “–verbose” switch to no avail. Same results. I even tried starting the program as root.
Gimp version is 2.10 and I have tried a fresh install of all “gimp” packages as well as trying a different version from one of the alternate Tumbleweed repositories.

what’s your repo list

zypper lr -d

try running

zypper ve

to check all your dependencies are fine
afaik the current gimp for TW is at version 2.10.4 run an update

zypper dup

How do you update? If not by ‘zypper dup’ then that’s wrong. Tw should only be updated by ‘zypper dup’

zypper lr -d
Repository priorities in effect:                        (See 'zypper lr -P' for details)
      97 (raised priority)  :  1 repository  
      98 (raised priority)  :  4 repositories
      99 (default priority) :  8 repositories

#  | Alias                            | Name                      | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                                  | Service
 1 | 2018-01-04-DVD                   | 2018-01-04-DVD            | Yes     | (r ) Yes  | No      |   99     | yast2  | iso:///?iso=openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180104-Media.iso&url=dir%3A%2Fhome%2Fronnie%2FRepositories%2FOS |        
 2 | Mozilla                          | Mozilla                   | Yes     | (r ) Yes  | Yes     |   98     | rpm-md |                                               |        
 3 | Packman                          | Packman                   | Yes     | (r ) Yes  | Yes     |   97     | rpm-md |                                                  |        
 4 | Science                          | Science                   | Yes     | (r ) Yes  | Yes     |   98     | rpm-md |                                               |        
 5 | Wine                             | Wine                      | Yes     | (r ) Yes  | Yes     |   98     | rpm-md |                                       |        
 6 |    | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                                |        
 7 |        | Main Repository (DEBUG)   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                              |        
 8 |      | Main Repository (Sources) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                             |        
 9 |      | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                                    |        
10 | | Main Update Repository    | Yes     | (r ) Yes  | Yes     |   98     | rpm-md |                                                                      |        
11 | repo-src-non-oss                 | repo-src-non-oss          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                             |        
12 | repo-src-oss                     | repo-src-oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                                 |        
13 | teamviewer                       | TeamViewer - x86_64       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |         

The offbeat repos such as “science” and “teamviewer” are to get and keep packages that are not available in the standard repos.

I run “zypper verify” most every time there is an apparent problem. Currently I get “Dependencies of all installed packages are satisfied.”

I typically use Yast Online Update, but run “zypper dup --from” on occasion just to make sure that nothing was missed. As a general rule, and as is the output right now, “zypper dup” returns “nothing to do”. I also on occasion run “rpmdb --rebuilddb” just to make sure that there has not been a corruption.

My replies may be delayed because I almost never get email notifications concerning replies to threads.

My gimp version is 2.10.4-1.2 as well as matching gimp packages with the exception of gimp-help.

gimp-help version is 2.8.2-1.2 which is the newest available in any of my repos and appears to be the newest at all openSUSE repos.


Using TW 20180815 and GIMP 2.10.4-1.2 … starts and runs OK here. (Settings are now at “~/.config/GIMP/2.10” - I guess that’s the one you renamed).

you said you removed the .gimp dir but the issue persisted may I suggest you try a new user account as it may be something gtk3 related or even desktop related

I have the same issue with gimp-2.10. I update my system using ‘zypper dup’ and my current kernel is 4.18.0-1-default. I have also tried deleting the gimp user directory and run gimp with a different account and gimp shows the same behavior that it does not start. Unfortunately, I have no idea how to fix this problem.

Actually, I hope this problem can be solved very soon. For me, gimp is now dead as well, going just into a hanging mode when started, without any useful indication of what the problem is. I tried to re-install gimp, but it did not resolve this.

Maybe someone just needs to build 2.10 for opensuse?

@purevw, @jsberrios, @wolfgangcramer

You guys need to establish what is is your systems have in common.

As I wrote in an earlier post, TW and Gimp are working OK on a system here.


TW 20180818
Gimp 2.10.4-1.2
Plasma 5.13.4
Frameworks 5.48.0
Qt 5.11.1

Video is nouveau plus Mesa-dri-nouveau

My system is

Leap 15.0
KDE Plasma 5.13.4
KDE Frameworks 5.49.0
Qt 5.11.1
Kernel 4.12.14-lp150.12.16-default
Gimp is 2.10.4

Video is radeon and Wayland

My Gimp is also broken - tested from desktop icon as well as CLI.
Command line just hangs with no output info.
cntl-C kills on the command line, but the process is still running (per KsysGuard)

Interestingly, this works

gimp -v
GNU Image Manipulation Program version 2.10.4
git-describe: GIMP_2_10_2-356-ge384409fe5
C compiler:
        Using built-in specs.
        Reading specs from /usr/lib64/gcc/x86_64-suse-linux/7/defaults.spec
        Target: x86_64-suse-linux
        Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,ada,go --enable-offload-targets=hsa,nvptx-none=/usr/nvptx-none, --without-cuda-driver --enable-checking=release --disable-werror --with-gxx-include-dir=/usr/include/c++/7 --enable-ssp --disable-libssp --disable-libvtv --disable-libcc1 --disable-plugin --with-bugurl= --with-pkgversion='SUSE Linux' --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --with-gcc-major-version-only --enable-linker-build-id --enable-linux-futex --enable-gnu-indirect-function --program-suffix=-7 --without-system-libunwind --enable-multilib --with-arch-32=x86-64 --with-tune=generic --build=x86_64-suse-linux --host=x86_64-suse-linux
        Thread model: posix
        gcc version 7.3.1 20180323 [gcc-7-branch revision 258812] (SUSE Linux) 

using GEGL version 0.4.4 (compiled against version 0.4.4)
using GLib version 2.54.3 (compiled against version 2.54.3)
using GdkPixbuf version 2.36.10 (compiled against version 2.36.10)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.40.13 (compiled against version 1.40.13)
using Fontconfig version 2.12.6 (compiled against version 2.12.6)
using Cairo version 1.15.10 (compiled against version 1.15.10)

Killing a job from CLI yields

Segmentation fault (core dumped)

This is about Tumbleweed and Gimp 2.10 is in Tw. FWIW Gimp 2.10 on KDE, working fine.

Well, OK, I’ll log a new item for Leap 15.
Seems very similar to the TW results at the moment for some folks, but not others.

I know wayland is the future but afaik wayland is still buggy on plasma 5 have you tried using X
I use X on LEAP 15.0 and gimp 2.10.4 works fine

I can also say that “gimp -v” now has a similar output as the previous post, but gimp still will not go.
I have tried while in LXDE, Wayland, and Plasma, so I don’t think it is a window manager or desktop issue.
One thing that I might add, the original gimp config folder that I renamed is still as I left it, but a new gimp folder has never been created, so something is apparently failing before gimp progresses far enough to create a default config folder.
I have run “gimp -v” and “gimp” from a terminal, and have also tried to open gimp via menu shortcuts.

I tried adding a different user. Same results. I checked my gtk packages and all seem to be from the same repo and same version. Still no joy.

well your repos look fine, and if it’s not a user issue then I’m guessing it’s a system one
you said this happened after an update so
as opensuse keeps the 3 last kernels installed I’d suggest booting into an earlier kernel and see if the issue was caused by something in the new kernel
or if you are using btrfs you could do a roll back to an earlier snapshot (you can always do an update with zypper dup)
you should run

zypper verify

to check if there are any package discrepancies
if gimp works with an older kernel or from an earlier snapshot I’d suggest opening a bug report over at opensuse’s bugzilla a quick search there reveals that nobody has reported an issue similar to yours

Hi. Just looked, as I am running 15.0. The only version in the repos for 15.0 is 2.8.22 AFAICS. If so, then you installed 2.10.xxxx in a different then default manner. How?

(Yes, I know you are not having a problem, but I am wondering how you have 2.10.4 in Leap 15.0):wink:

Next time I am TW, which will be later Saturday, I will take a look at the GIMP, will report back on my experiences.