Gimp cant open any image previously edited with Gimp itself

Starting from Opensuse 11, I have been experiencing a weird problem with Gimp. It persists with any version of it, won’t disappear after any update. I have the latest version (2.4.6).

Whenever I open an image with Gimp, its all fine, then whatever editing i do, even just cropping, and then save as a normal jpeg (or any other format) at the next time i attempt to open the image with gimp, i’m returned the error in the screeshot below (plug-in crashed: jpeg).

Any other image program can open the Gimp-edited image just fine.
If i save the image from Gimp without modifications, then the problem does not appear.
I already tried uninstalling gimp and reinstalling, no luck.
I also tried playing with the settings that are proposed when you export an image into a jpeg. None of them affects the problem.

I’m out of ideas, it doesn’t seem to be a common problem, as i cannot find much googling. It’s really annoying so i suppose if many other people had the same problem i would find threads around.
I dont have any other problems handling image files with any program at all. I’m on a 32 bit OS.

Anyone has any idea?? Thanks!