Gimp 2.6?

Hi , how can I make it work? I tried community, factory, photo/multimedia repository , by installing it from, but non of them works. When I try to upgrade it from Yast , it tells me that I have deinstall openoffice (???) PLease help .

it works for me. without any problem. I have oo 2.4 gnome 2.2 and gimp 2.6

no problem with dependencies…

what exactly packages make problem to you?

openoffice 3.

Still no problems.
Copy&paste the exact output from

zypper -v in 'gimp >= 2.6'

opensuse 11.0 x86
gimp 2.6.x works for me with ooo 3.0 without any problem as did installing them.

I’ve done that. Gimp doesn’t start when I click on an icon, and when I try to run it from the command line, I get this output >

linux-qjos:/home/david # gimp
gimp: symbol lookup error: /usr/lib/ undefined symbol: g_dgettext

It looks like I have to downgrade it again :frowning:

Ha , I installed libgegl0.0 (I had just libgegl-0_0-0) and it works flawlessly. Problem randomly solved :open_mouth:

One more question . Is that zypper command good for any upgrade?

The way RPMs are created makes this error impossible. Or you ignored dependencies (ZYpp gives you this option, but don’t use it if you don’t understand it) or you have wrong repositories (Factory mixed with 11.0 or GNOME:UNSTABLE, etc.).

The command says “from all the available gimp packages with version higher or equal to 2.6, install the one from the repository with the highest priority”… it’s the good command if that’s what you want.
A normal upgrade is done with “zypper -v up -t package”.