Gigabyte GA-EX58-DS4 and the Realtek 8111D NIC

Alright i have just converted from Ubuntu to Suse and ive come across my first problem. I am unable to obtain internet access. As stated in the post title i am running a Realtek NIC, the output of ifconfig -a results in two devices, lo and pan0. I have configured the network settings multiple times, but am unable to access anything.

So my question is, is this NIC supported, if so what steps can i take to rectify this situation. If its not supported what other options do i have?

Thank you for your time, enjoying the 11.1 release

Just an update, i have tried to install both drivers from the realtek website, both r8168 and r8169, they both are inserted into the kernel, but ifconfig still shows no ethx. any suggestions ?

I’m running the board fine with 11.1 - BUT - the network device seems to fall into “sleep”-status when machine is shutdown. The only way to restart NetWork I found so far is: CMOS Clear ( turning of power, press “clear cmos values” + reconfigure all your settings in BIOS again - or load from stored fugures ).
If anyone has an idea - how to avoid the “full shutoff” of the network device - would be a great help.
bye Tommy

I’m having the same problem. I swapped my power supply and suddenly I got networking for a bit. On all subsequent boots I got no networking. I’ve been doing a full power down, ie by flipping the switch in the back, and it’s still not working. I’m not sure what you mean by reset the CMOS in the BIOS or why that would help. I tried resetting the BIOS settings to factory defaults and then fixing things from there, but that didn’t help either. Any thoughts on how to fix this or links to a patch in the pipeline? I’m not sure if this is relevant:
LKML: Francois Romieu: [PATCH 0/14] Pull request for ‘r8169’ branch

Just a thought here. This often happens when rebooting from windows, which hogs the nic.
Powering off between windows and linux often resolves this

/Geoff

I found that once i built the kernel module and shutdown the computer, i pulled all power from the box booted the computer up and all is fine. Found this completely by accident, but its been working for quite some time now.

a) CMOS/BIOS - on some motherboards you need to shorten 2 pins; on my motherboard I have a small button - pressing this button when power is turned of - sets back all settings stored to factory level.
b) in the meantime I have downloaded new Realtek-driver (http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false) , removed old module r8168 and installed new r8168. Everything works fine. Network device now starts in Gigabit-mode ( the origin OpenSuse 11.1 did only start in 100MBit ).
Until now no CMOS/BIOS clear were needed.

I am also having quite some trouble with this device.

What I found was that i was able to run modprobe with an option, like speed=1000. This seemed to kick the driver into life. Still won’t persist after a reboot though :’(

Same problem on the GA-EX58-Extreme which has two Realtek 8111D NICs. Found that clearing CMOS isn’t required; just turning off the power supply seems to work. Also make sure that the “Green LAN” option isn’t enabled in the BIOS. You can usually tell that the device(s) won’t be seen on boot if the BIOS LAN Test doesn’t run, i.e. if it can’t/won’t/doesn’t probe the cable on a LAN Test, the device won’t show up on boot.

Got a bit further today. I disabled the onboard NIC and now my other r8169 based NIC is working perfectly. Why do you need to disble the onboard NIC to get another PCI slot NIC to be visible by the BIOS?

I think that Gigabyte need to get some work done on this bios, and quick!!

The GA-EX58-extreme has two on-board r8169 based NICs. My system also has a PCIe wireless NIC. I always see the wireless on boot, but sometimes see only one on-board NIC and sometimes no on-board NICs on boot. I’ve submitted a query/bug report to Gigabyte about this but haven’t heard anything back yet. I am running with the very latest Rev of firmware on the motherboard.

I also experiance the bios sleep problem, however it’s only on SUSE! I have used many distros in the past Gentoo, Fedora, and Arch and only on SUSE does my card automatically go to sleep. I’ve tried the r8169 drivers compiled in the kernel, and I’ve tried the RealTek r8168 from build service.

There is no way to tell if the card is in sleep mode, it just doesn’t say it in any human form if it is. However there are 3 ways to get it out, shutting off power completely to your PC for about 25 seconds, clearing the CMOS, or what I like to call “jittering it” ie remove and install the module r8169 or r8168 mutliple times until it connects. Here’s pretty much a sample of the dmesg from that:


vendor=8086 device=2948                                                        
r8169 0000:04:00.0: PCI INT A disabled
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
vendor=8086 device=2948
r8169 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
r8169 0000:04:00.0: setting latency timer to 64
eth0: RTL8168b/8111b at 0xffffc20000656000, 00:1a:4d:4b:1c:47, XID 38000000 IRQ 4347
r8169: eth0: link down
r8169: eth0: link down
r8169: eth0: link up
r8169: eth0: link up
vendor=8086 device=2948
r8169 0000:04:00.0: PCI INT A disabled
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
vendor=8086 device=2948
r8169 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
r8169 0000:04:00.0: setting latency timer to 64
eth0: RTL8168b/8111b at 0xffffc20000656000, 00:1a:4d:4b:1c:47, XID 38000000 IRQ 4347
r8169: eth0: link down
r8169: eth0: link down
r8169: eth0: link up
r8169: eth0: link up

This problem exists on DHCP, static and Network Manager connections for such Realtek cards. And ethtool does not work with the kernel or realtek drivers. This has also lead to problems with Windows, because the Windows drivers don’t expect the card to be on sleep mode either, because of a previous problem with the card where you had to set the Windows partition make the card Wake on Lan. However for some reason or another the Windows settings are overwritten with the card and it goes to sleep anyway instead of wake on lan with windows.

If you’re experiencing problems with this card try this, edit /etc/sysconfig/network/ifcfg-eth* where * is your card’s number.

Find the line:

ETHTOOL_OPTIONS=’’

Set it to:

ETHTOOL_OPTIONS=‘port tp’

I’m pretty sure for some reason under both drivers r8169 and r8168 SUSE has problems detecting the port, this will set it to use the twisted pair (RJ45) port. I don’t know of an automatic fix if you’re using network manager unfortunately. But if you need the card try typing ethtool -s eth0 port tp before connecting with it via network manager.

Got a little more info/experience with this. It appears there’s a problem in the Linux drivers. Various versions of Linux (based on the same Kernel) all show similar problems. I can get it to work on the 32-bit version of 11.1 by turning off the power supply; just clearing the CMOS doesn’t always work. However these same tricks don’t work with the 64-bit version of 11.1; never could find anything that would make the interface work there. The problem also doesn’t seem to be a BIOS issue as this isn’t seen when running Windows-XP or FreeBSD 7.0/7.1.

I can confirm that the same problem exists also in Ubuntu 8.10 x64.
It may be a driver bug or a bios bug + driver bug.
The problem rises especially in 64 bits systems

Has anyone more details, or a confirmed working solution?

Many thanks
nkef

I can confirm that the same problem exists also in Ubuntu 8.10 x64.
It may be a driver bug or a bios bug + driver bug.
The problem rises especially in 64 bits systems

Has anyone more details, or a confirmed working solution?

Many thanks
nkef

Confirming same problem with Gigabyte GA-EX58-UD3R using Ubuntu 8.10 x64.

This is a known Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/356819

As one might expect, the same problem with the Realtek 8111D NIC not being seen and supplied a kernel driver occurred on the Gigabyte GA-EX58-UD5 board I have just started using. The NIC was noticed and initialized after complete system power down and cold
boot.

OS: Both Ubuntu 9.04 and openSUSE 11.1 for amd64 (on Intel Core i7).

I have a laptop and a desktop with an AsRock board, both having a NIC reported as RealTek 8111/8168b, and both have NEVER seen a Windows installation.

  • Suse 11.1 default installation
  • after a cold start, the module for the card is almost always loaded, but in 19 out of 20 times there’s no network connection possible
  • after a reboot, the card almost never shows up, but if it shows up, network is running.

I’ve tried the newest driver from the RealTek site, every ethtool option mentioned here (and in a couple of other forums, too), no difference.

As of today it seems this card is not Linux compatible, even when RealTek claims otherwise.

Tom