Giant fonts and window borders after update

After the last update (see below), I have an odd problem with some fonts, title bars and borders being presented HUGE!

I’ve attached an example screenshot, and as you can see, the notifications pop up takes up half the screen!

https://ibb.co/mX6RZJ

I’ve tried creating a new account and logging in but it has the same problem so it’s not a specific configuration corruption.

Some info that may be useful but let me know what else might help.
Thanks.

bachman:~ # cat /etc/os-release
NAME=“openSUSE Tumbleweed”

VERSION=“20180712”

ID=“opensuse-tumbleweed”
ID_LIKE=“opensuse suse”
VERSION_ID=“20180712”
PRETTY_NAME=“openSUSE Tumbleweed”
ANSI_COLOR=“0;32”
CPE_NAME=“cpe:/o:opensuse:tumbleweed:20180712”

Graphics: VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
https://ibb.co/mX6RZJ

Was this really an “update”? Check any of several other threads as to why this is inappropriate and tend to break things.

If you actually performed a “sudo zypper dist-upgrade”, then make sure that you are only using openSUSE signed tumbleweed/repo/oss and non-oss repositories. The only reliable alien repository is Packman.

If unsure post

zypper lr -Eu

Thanks for your help.

The sequence I used to update was:

zypper ref
zypper dup

The only unusual thing about this update was that an earlier update a couple of months ago completely messed up WiFi; I couldn’t connect to anything, so I backed out the whole update. I didn’t get to do another update until a few days ago.

My repos are:



# | Alias                                  | Name                        | Enabled | GPG Check | Refresh | URI                                                  
--+----------------------------------------+-----------------------------+---------+-----------+---------+------------------------------------------------------
1 | libdvdcss                              | libdvdcss                   | Yes     | (r ) Yes  | Yes     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/  
2 | openSUSE-20171001-0                    | openSUSE-20171001-0         | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/    
3 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository        | Yes     | (r ) Yes  | Yes     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/  
4 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository          | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed/    
6 | repo-non-oss                           | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss/
8 | repo-update                            | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/      

Please use the code Tags (the # icon above the forum edit pane) to display commands and their output.

Repositories #1 and #3 seem to be duplicates, and are mostly redundant nowadays.

I would change the Workspace Themes and Application Style settings. The artwork changed recently, and I found some configurations that were not working properly responde to being changed, applied, and changed back again.

Again, thanks for your help.

I’ve spent a while hunting around the themes and settings for anything that might affect this. Also, I mentioned in my original post that I created a new user to check the default set-up and that also gets the huge fonts and borders - so I suspect it’s not a simple personal configuration issue.

If I could find where these values are set, I could probably fix this but I haven’t been able to.

Which WM or DE(s) are you using?

What is the output from

xdpyinfo | egrep 'dimen|ution'; xrdb -query | grep dpi; inxi -G -c0

in an Xterm, Konsole, etc? You likely need to install inxi with zypper or YaST2.

Set the DPI ( probably detected wrong ) like this in /etc/sddm.conf

[X11]EnableHiDPI=true
ServerArguments=-dpi 96

and try changing the ‘96’ to ‘120’ or ‘140’. Needs a restart of the X server, so better reboot

I ran this after I’d updated sddm.conf as suggested in another reply.

  dimensions:    1920x1080 pixels (507x285 millimeters)
  resolution:    96x96 dots per inch
Graphics:  Card-1: Intel HD Graphics 620 driver: i915 v: kernel  
           Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,intel,vesa  
           resolution: 1920x1080~60Hz  
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.1.3 


Thanks.

This is how sddm.conf looks now: (blank lines removed)

cat /etc/sddm.conf
[Theme]
# Cursor theme used in the greeter
# Current theme name
[XDisplay]
# The lowest virtual terminal number that will be used.
# Path to a script to execute when starting the display server
[X11]
EnableHiDPI=true
ServerArguments=-dpi 96

The X11 section didn’t exist before I just added it.

This update has fixed the logon screen which I hadn’t mentioned before but which was also presented in very large text. Nothing else seems to have improved.

Thanks.

XFCE? LXQT? E2? Plasma? Mate? Cinnamon? More than one?

xrdb -query | grep dpi

returned blank? Sometimes it’s expected, sometimes it’s not. In your case, returning blank might be part of the problem. If Plasma, you can make it 96 or 120 in systemsettings (personal settings/configure desktop) > fonts > force fonts dpi. In other DEs, Xft.dpi, which xrdb tested for, can be set directly in ~/.Xresources, e.g.:

Xft.dpi:108

What size is your 1920x1080 screen?

If Firefox or Thunderbird are the primary complaint, Xft.dpi might do what you want, or you might need or want to use one of their hidden preferences that can be changed in about:config, layout.css.devPixelsPerPx most likely. It defaults IIRC to -1.0. You might want 1.0, 1.1, 1.25 or possibly more.

Sorry. I didn’t understand the question. It’s Plasma

xrdb -query | grep dpi

returned blank? Sometimes it’s expected, sometimes it’s not. In your case, returning blank might be part of the problem. If Plasma, you can make it 96 or 120 in systemsettings (personal settings/configure desktop) > fonts > force fonts dpi.

That’s cracked it! :slight_smile:

Forcing fonts dpi to 96 has restored sanity to my desktop. Many thanks.

I looked at this a few times while trying to fix this and it was already set to 96dpi but when I went there just now it was unset. Very bizarre.

Thanks to everyone who came to help. I’m happy now.

Which TW version did you update to 20180712 from? If you don’t remember, you can grep for it in /var/log/zypper.log or /var/log/zypp/history. If it was several months since this could be a result of the fix to https://bugzilla.opensuse.org/show_bug.cgi?id=1022830

I don’t know how to find the actual TW version number but these are the dates I did the updates - taken from /var/log/zypp/history. I assume it’s pretty easy to find which version that would have been.
There would have been one after the April update but it wrecked WiFi so I backed it out. I didn’t have time to figure it out then and needed it working.

2018-04-01 08:11:03|command|root@bachman|'zypper' 'dup'|
2018-04-11 14:15:19|command|root@bachman|'zypper' 'dup'|
2018-07-15 08:59:21|command|root@bachman|'zypper' 'dup'|
2018-07-18 08:09:36|command|root@bachman|'zypper' 'dup'|
2018-07-18 20:16:27|command|root@bachman|'zypper' 'dup'|

It turns out bug 1022830 fix would not have been involved, fixed much longer ago than I realized, 12 months.

Same exact thing happened to me. I rolled back the update to fix it. Good to know there’s a fix if it happens again, but I’ve been extremely reluctant to update after this happened. This is the 2nd update that has broken things for me. The first time Plasma was COMPLETELY unusable. That time, I submitted a bug report and it was completely ignored, so I had to resort to a complete reinstall. I don’t see a whole lot of support when things go wrong with Tumbleweed, so I feel like perhaps it’s time for me to abandon this distro and switch to something that has better support.

Interesting resolution. I don’t have “Force Fonts DPI” enabled, and my “xrdb -query | grep dpi” is blank, but no issues here.

Hi, welcome.

A couple of things: That your bugreport has not ( yet ) been replied to is not the way it should be. Defintely not, and it’s not the normal way things go around Tumbleweed. But … talking about updates and Tumbleweed and KDE always triggers something:
How did you update ? Per KDE updater applet? YaST? None of these should be used on Tw, only

zypper dup

is supported. And nothing else.
To eleborate: Tw is released over and over again, as a whole distro. This means downgrades, architecture changes etc can be part of the upgrade. Neither YaST, nor the KDE updater can handle this, and it can lead to a mix of KDE packages from different builds.

And about support for Tw: check these forums, and you’ll see that support is there, with a relatively high percentage of solved issues ( we don’t mark as solved, but still ).

Hi Knurpht,

Thanks for your reply! I agree that bug reports shouldn’t be ignored! Even if someone just comments “this isn’t on our end” or something like that, then we’d at least know that someone is out there and paying attention.

To update my system I always use

sudo zypper dup

and never yast or KDE updater. Here’s my repos:

# | Alias               | Name                        | Enabled | GPG Check | Refresh
--+---------------------+-----------------------------+---------+-----------+--------
1 | google-chrome       | google-chrome               | Yes     | (r ) Yes  | Yes     
2 | openSUSE-20180530-0 | openSUSE-20180530-0         | No      | ----      | ----
3 | packman             | packman                     | Yes     | (r ) Yes  | Yes     
4 | repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----
5 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     
6 | repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     
7 | repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | ----
8 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes   

I know the OPs issue has been resolved, but why did it happen in the first place? Since the fix has been posted here, I will run an update now and see if it happens again.

I just ran the update and the same thing happened. I went in and ticked the box to force fonts DPI to 96, but the splash screen still has the gigantic font. This fix is just a band-aid because whatever is causing the problem is still going on.

Changes in desktop settings are personal. They have no applicability to the login manager. If the forcing is needed for the greeter, do it either through greeter settings, or globally in /etc/X11. Did you read comment 10?

What exactly is the “splash screen” that has the “gigantic font”? Most splashes have no text, just bling to pass the time until loading completes.

What size and resolution is/are your display(s)?