Ghostscript and FreeType problems

Every time I convert a .ps figure new using gs I end up with

PL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1

This happens both with 11.4 and 12.1 (x86_64).



zypper lr -p
#  | Alias                              | Name                               | Enabled | Refresh | Priority
---+------------------------------------+------------------------------------+---------+---------+---------
 1 | Application:Geo                    | Application:Geo                    | Yes     | Yes     |   99    
 2 | Packman Repository                 | Packman Repository                 | Yes     | Yes     |   90    
 3 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes     | Yes     |   90    
 4 | Wine                               | Wine                               | Yes     | Yes     |   99    
 5 | libdvdcss repository               | libdvdcss repository               | Yes     | Yes     |   99    
 6 | openSUSE-12.1-12.1-1.4             | openSUSE-12.1-12.1-1.4             | No      | No      |   99    
 7 | repo-debug                         | openSUSE-12.1-Debug                | No      | Yes     |   99    
 8 | repo-debug-update                  | openSUSE-12.1-Update-Debug         | No      | Yes     |   99    
 9 | repo-non-oss                       | openSUSE-12.1-Non-Oss              | Yes     | Yes     |   90    
10 | repo-oss                           | openSUSE-12.1-Oss                  | Yes     | Yes     |   90    
11 | repo-source                        | openSUSE-12.1-Source               | No      | Yes     |   99    
12 | science                            | science                            | Yes     | Yes     |   99

Any ideas?

Thanks,
Andri

I don’t use gs, but when I printed a web page to file (.ps format), then executed

gs mozilla.ps

I got no error.

What form of the command are you using.?

For reference, I have

 # rpm -qa|grep ghost
ghostscript-library-9.00-4.10.1.x86_64
ghostscript-fonts-other-9.00-4.10.1.noarch
ghostscript-fonts-std-9.00-4.10.1.noarch
OpenPrintingPPDs-ghostscript-4.0.0-7.1.noarch
ghostscript-x11-9.00-4.10.1.x86_64

For instance


> convert -density 300 -scale 30% -rotate +90 gatalump.ps gatalump.png
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1

and


ps2pdf gatalump.ps 
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1


> rpm -qa | grep -i ghost
ghostview-1.5-431.1.3.x86_64
ghostscript-fonts-std-9.00-13.1.3.noarch
ghostscript-library-9.00-13.1.3.x86_64
OpenPrintingPPDs-ghostscript-4.0.0-11.1.2.noarch
ghostscript-fonts-other-9.00-13.1.3.noarch
ghostscript-x11-9.00-13.1.3.x86_64

On 2012-05-09 13:36, plesset wrote:
>
> For instance
>
> Code:
> --------------------
>
> > convert -density 300 -scale 30% -rotate +90 gatalump.ps gatalump.png
> GPL Ghostscript 9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
> GPL Ghostscript 9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
> GPL Ghostscript 9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
>
> --------------------

I tried that same command line in my 11.4, no problem. Maybe the problem
triggers on your ps file.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

That particular figure was generated with the GMT package, which I have found to be very reliable. I just tried to make a simple figure using gnuplot


gnuplot> set grid
gnuplot> unset key
gnuplot> plot sin(x) w l
gnuplot> set term postscript enhanced landscape color solid "Helvetica" 16
Terminal type set to 'postscript'
Options are 'landscape enhanced defaultplex \
   leveldefault color colortext \
   solid dashlength 1.0 linewidth 1.0 butt noclip \
   palfuncparam 2000,0.003 \
   "Helvetica" 16 '
gnuplot> set output "sin.ps"
gnuplot> rep

 
> convert -density 300 -scale 30% -rotate +90 sin.ps sin.png
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
GPL Ghostscript  9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1

which results in the same result.

Am 09.05.2012 13:36, schrieb plesset:
> GPL Ghostscript 9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
>
From this discussion
https://bbs.archlinux.org/viewtopic.php?id=137638
it looks like that this is a freetype problem not a ghostscript problem,
not sure about the right way to solve it.


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.3 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.3 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Am 09.05.2012 15:52, schrieb Martin Helm:
> Am 09.05.2012 13:36, schrieb plesset:
>> GPL Ghostscript 9.00: Error: Font Renderer Plugin ( FreeType ) return code = -1
>>
> From this discussion
> https://bbs.archlinux.org/viewtopic.php?id=137638
> it looks like that this is a freetype problem not a ghostscript problem,
> not sure about the right way to solve it.
>
Just as info, I tried your convert command with an one page postscript
file and got no error or warning and the resulting png looks correct.
The freetype library I use is libfreetype6-2.4.8-120.1.x86_64 from the
home:muzlocker repository (for subpixel hinting).

So maybe you can solve your problem by switching to a different freetype
version than the default one.


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.3 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.3 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

OK, thanks Martin. I included the Factory repo and updated the libfreetype package to 2.4.9, along with everything ghost*. That seems to work, at least the tedious error messages have disappeared.

You mention something about subpixel hinting, can you clarify on that?

Am 09.05.2012 19:36, schrieb plesset:
>
> OK, thanks Martin. I included the Factory repo and updated the
> libfreetype package to 2.4.9, along with everything ghost*. That seems
> to work, at least the tedious error messages have disappeared.
>
> You mention something about subpixel hinting, can you clarify on that?
>
>
I mentioned the subpixel hinting only as an info why I have a different
freetype library. Some people (including me) are not satisfied with the
standard way the default library deals with smoothing of the fonts. So
several alternatives from the open build service are available which do
it in a different way and also from the opensuse-community web page

(For example http://opensuse-community.org/SubpixelHinting)

if you are satisfied with the way it is done by default don’t care about
it. It is mostly a matter of personal taste and not something really
technical.

Be careful with the factory repo that you do not mixup your packages
with the unstable factory. I would disable it after the packages which
seem to work for you are installed to avoid trouble in the future.


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.3 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.3 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

On 2012-05-09 15:06, plesset wrote:
>
> That particular figure was generated with the GMT package, which I have
> found to be very reliable. I just tried to make a simple figure using
> gnuplot

> which results in the same result.

Yes, I get the same error. gv displays it, but has a “silent” error.

You could do a bugzilla about it.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)