gfx boot loading screen

Testing a Laptop with a live CD proved the gfxboot menu and loading screen during loading. After installing, I am seeing the “behind the scenes” of linux loading and showing done in green.

How do I get the graphical system loading screen shown?


Do you mean you see scrolling text as the computer boots - But you would rather see the green splash:

Yeah. I bought a laptop for my teenage daughter who says seeing scrolling text isnt as pretty as the green splash loading screen…LOL The loading splash screen did work on the KDE Live image I tested with prior to purchasing laptop.

I was unaware what it was called, I thought the splash screen only referred to the GRUB menu screen. Thanks for the clarification.


It might not be pretty, but it might be for a reason. It’s possible we can get it working. But you’ll not like all the command line stuff I’m going to put you thru.

Do you know how to use the terminal and become su in it?
Become su in Terminal - HowTo - openSUSE Forums

Do this and post result of this:

cat /boot/grub/menu.lst

FYI: I am familiar with terminal and command line as all my SLES servers sit at init 3 unless I really need a gui. pretty close to 50/50 is usage of GUI/CLI.

Modified by YaST2. Last modification on Fri Dec 25 23:09:00 PST 2009


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2 -
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-Hitachi_HTS543216L9SA00_090910FB22015CFL3UHA-part6 resume=/dev/disk/by-id/ata-Hitachi_HTS543216L9SA00_090910FB22015CFL3UHA-part5 splash=silent quiet showopts
initrd /boot/initrd-

I did try removing splash= silent with no luck and I set the monitor dimentions via gfxboot too 1024x600.

Thanks for your help.

BTW: I am using OpenSuSE 11.2 32 bit.

You could try adding


You can type that in manually just to try it

Ok, I got a “Undefined video mode number: 317”
Press <enter> to see video modes…

Mode: Resolution Type:
0 F00 80X25 VGA
1 F01 80X50 VGA
2 F02 80X43 VGA
3 F03 80X28 VGA
4 F05 80X30 VGA
5 F06 80X34 VGA
6 F07 80X60 VGA
7 312 640X480X32 VESA
8 314 800X600X16 VESA
9 315 800X600X32 VESA
a 301 640X480X8 VESA
b 303 800X600X8 VESA
c 311 640X480X16 VESA

Enter a video mode:

I have tried entering various versions of the above numbers.


I wander what module has been added to the Live Kernel?

Check this thread
Splash=silent Not Working - openSUSE Forums

Well, I am still having no luck. I have done the following…

mkinitrd -s 1024x600
hwinfo --framebuffer which returned 6 configurations of 640x480 & 800x600

The things that failed was…
cat /proc/splash
echo 1 > /proc/splash

This is kicking my butt…

Just to be sure remember that Linux is case sensitive.

Do you get an error with cat /proc/splash ?? Or just nothing?

just to be sure do a

ls -l /proc and see if you see a file ( it is actually a process but all things in Linux are files) with the name splash.

Tell use about the hardware is it any way odd? Did you install the OS or did it come pre-installed?

cat /proc/splash resulted in no file or folder, as well as when I tried to do a echo 1 > /proc/splash.

Although I had one time when /proc/splash was there. But the contents showed to be off.

Its a ACER Aspire One D250 which is a 10.1 inch netbook.
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)

All in all, a nicely put together system.


In terminal as su try this:

hwinfo --framebuffer

and please post the result

hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer
[Created at bios.459]
Unique ID: rdCR.il6towt04X5
Hardware Class: framebuffer
Model: “Intel(r) 82945GM Chipset Family Graphics Controller”
Vendor: “Intel Corporation”
Device: “Intel(r) 82945GM Chipset Family Graphics Controller”
SubVendor: “Intel(r) 82945GM Chipset Family Graphics Chip Accelerated VGA BIOS”
Revision: “Hardware Version 0.0”
Memory Size: 7 MB + 704 kB
Memory Range: 0x40000000-0x407affff (rw)
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+832), 8 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Config Status: cfg=no, avail=yes, need=no, active=unknown

This Intel chipset is problematic IIRC

Try: 0x314

bootsplash:… no good signature found.

If vga=0x314 worked, then it looks like the system cant find a good image.

Should we take that that approch?


Anyways, then why does my system with a PCI-X nVidia do the same thing?

Isn’t that a rather antiquated graphics device?

Personally I wouldn’t stress too much over it. 11.2 boots so quickly you don’t see the splash for long anyway.

I’m just going to experiment…I’ll be back.