Getting wifi to work from the CLI

Hi Everybody,
I am on OpenSuse11. My wifi works fine when
I use knetworkmanager. But now I have installed
xmonad and don’t want to use a GUI to get my
wifi working. But without knetworkmanager, I
can’t seem to get my wifi working. When I use
iwconfig, I get:

linux-w402:/home/santanu # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:off/any Nickname:“ipw2100”
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:16 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:6 Missed beacon:0

“iwlist scan” shows:

eth1 Scan completed :
Cell 01 - Address: 00:50:F1:12:12:10
Protocol:IEEE 802.11bg
Frequency:2.412 GHz (Channel 1)
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Quality:68 Signal level:0 Noise level:0
Extra: Last beacon: 240ms ago

using iwconfig I can set the essid value,
but whatever I do, I can’t get the wifi to
get associated with the access point. Well,
“/etc/init.d/network restart” does it, but
then as soon as I use dhclient on the eth1
interface, it again becomes unassociated.
I am quite new to this wifi thing and I
must be missing something here (no
authentication is being used).

Could you please point me to some documentation
that explains in details how to get wifi
associated with an access point from the

Perhaps network manager is still interfering in the background?

You can tell SuSE not to use network manager at all under the “Global Options” tab in the “Network Settings” dialog in YaST.

Set it to the “traditional ifup” way of configuring the network, and maybe network manager will stop interfering then.

ifup / ifdown is the way SuSE used to configure the network in the old days, and is well documented on the googleinterwebnet.


Thanks. I think you are right. I found that the following
two commands bring my wifi connection running:

service network stop

## At this point iwconfig shoes ‘Associated’ !

dhclient eth1

## At this point, my wifi is up with an ip address

## acquired from the wifi router

Santanu Chatterjee