Getting sound only from one app while running multiple apps

I’ve always had problem with sound on my laptop and opensuse 64 bit. Now, it has started to give sound only for one app running on my laptop. I mean if I run amarok first, than mplayer, I get sound only from amarok. Is there any idea about it? Thanks
Here is my script info link:

Normal behaviour for Linux. Close one before starting the other.

But I remember that one that (I don’t remember which one time :slight_smile: I was getting sound at the same time with multiple apps running on.

Maybe, but not really my speciality - See if ‘oldcpu’ drops by…

reis3k , if you are curious, you could brush up on some openSUSE Linux sound concepts so you can understand the limitations of sound in Linux. Sound-concepts - openSUSE

Most Linux sound daemons/servers will NOT allow more than one application to share the sound. Hence if one sound device is using the sound, another is not allowed to use it.

The exceptions to that are the alsa api and pulse audio (where they WILL share the audio). Pulse audio is relatively new, and it was implemented in part to specifically allow multiple applications to share the sound device. However pulse audio is buggy. Real buggy … Did I say pulse was buggy?

The alsa api “route” is what I often try to set up on my PC. Maybe someday I’ll switch to tuning pulse … but its not there yet, and neither am I. Pulse is still buggy. You will find many applications allow one to select the sound engine, and hence one can often select the output sound module (or sound engine) to be pulse, or alsa. I usually select alsa when it is a choice.

For example, In the case of Amarok, one can select “xine” to be the sound engine. After selecting that, one can then separately launch “xine” (assuming one has installed ‘xine-ui’ (the xine user interface)) and in “xine” select alsa as the output sound module. By doing that, Amarok is using the alsa api and hence it will share the audio device with other applications that also use the alsa api.

In the case of mplayer, if one is using the smplayer front end (which I recommend) one can do the same in terms of selecting the alsa api. Hence in that case, with both smplayer and amarok using the alsa api, they should share the audio device (and sound will come from both simultaneous).

Its not easy to tune to the alsa api, and thats why pulse is being implemented to eventually make this easier such that all applications will be able to share sound. … but , … did I say pulse was buggy ?


First of all, I installed xine-ui but it didn’t add any different ui to amarok that it has before. I think it’s a standalone multimedia player of xine.

At the backend tab of amarok, there is a priority list having Xine as a first choice and gstreamer as second. But when I click on xine, it doesn’t offer any advanced properties about sound except some deinterlace properties. However, at the first tab of amarok sound and video configuration, there is a device preference which I believe directly connected to suse’s main device properties. I mean if I change it, all the application’s audio output and capture properties will change. Yeah, at that list (again priority list) first choice is pulse and second HDA Intel. I made it HDA Intel for all device list.

For the smplayer, it was already alsa - hda intel selected. In the list. there was also bare “alsa”, but I don’t think that it makes difference.

From yast, audio properties, I disabled pulse audio option.

Finally, I tried amarok and smplayer after the restarted but it was the same, except I started to get a notification when system restarts saying there was a error with audio device and it’s turned to default.

You mentioned pulse as a buggy too much, and I decided to remove all the instances. I searched for pulse and removed everything except libpulse0 and libpulse0-32bit, because they wanted me to change many things that I afraid to do.

I restarted system and run amarok and smplayer again. It was the same, BUT AFTER I CHANGE THE AUDIO OUTPUT property from “alsa (0.0 - HDA Intel)” to “alsa”, I GOT MULTIPLE SOUND. SO, at the moment, I can run more than one apps requiring audio at the same time (including the flash player on firefox).

Thanks for the suggestions. I hope they will make a fix to my laptop’s mute problem (I have to switch on mute button on my laptop, cos it disables it by itself after every restarts) after restarts.

I do not know what to say , other than you need to try harder.

I can play sound with xine and amarok and smplayer at the same time.

xine settings:](

amarok settings:](


I’m doing it right now.

The settings you refer to in xine make no sense.

ok … Great !!

Glad to read you succeeded. You had me wondering for a while. :slight_smile:

I still have pulse installed on my PC. I did not remove it. BUT I did deselect it from my applications (choosing alsa instead).

Not on my machines. Notification sounds mix nicely with music. Music in Amarok and a DVB in Kaffeine, same thing.

I think there are some difference due to version on the screen caps. Here are mines.](](](](
Free Image Hosting by

It looks like you have a KDE4 version of amarok, so I can not guide you though the menu’s there.

But your limitation in xine-ui appears obvious to me. You need to go to the tab on the far left of the xine-ui setup configuration menu and select “master of the universe” (or something like that) to give you advanced permissions to change its menu. Restart xine, and then the menu selections will appear.

Yeah I saw now, but to play movies or audio I don’t use xine player. When I change the setting through xine player does it also affects the other apps using xine?

I do not know. I had assumed so (ie applied to the xine engine in general), but I could be wrong, and it might be specific to only the xine player.

It is probably best to test.

Does this hold also for 11.2?

I think pulse will be better in 11.2. Whether it will be “good enough” is something I don’t know. The sound hardware in my PCs works reasonable with pulse now, BUT many other sound devices do not work well. Hence I can only comment on my hardware wrt 11.2 milestone releases.

Well just to give my limited experience. I had similar trouble with sound not working simultaneously with multiple apps. I messed around with trying to get Alsa working but gave up with it.

I decided to give Pulse a proper go and set it up and have to say that I don’t have any problems with sound 99% of the time. I can play a movie in smplayer, receive mail notifications and play a youtube video at the same time with all the sound mixing through nicely.

I may be lucky or my sound demands may be simple but so far I find Pulse to work fine.

Oldcpu is the guru with sound on openSUSE but if your sound demands are fairly basic then it’s worth giving Pulse a go if you don’t have any joy with alsa.