Getting rid of recent activity

I want to get rid of recent activity in opensuse kde, I mean recent documents and recent saved files, I have noted that if you uncheck show recent documents but you enable it again it show your recent documents, it is registering activity even if disabled, if someone come to your pc it only has to enable the function again to see your recent files, before I just was a matter of doing a chmod 000 to the folder ~/.kde4/share/apps/RecentDocuments****

this is another thing, in dolphin there is a seccion that is registering your activity, how can I get rid of that? not hide, but remove it.


Sweeper is supposed to clean all this up in Plasma - but it doesn’t seem to work any more.
I just gave it a spin and specifically selected to clean up recent applications and documents. But nothing happened.

What happens if you do a right click on the header ‘recent documents’ and/or ‘recent applications’ and disable/delete it there? Doesn’t that clean out the list?

yes it does, but what I want is to disable the function, not only hide it, and also disable the recent documents in dolphin

It didn’t worked for me neither

I guess it is because sweeper is a plasma 4 application that hasn’t yet been ported to plasma 5.

there is a third party app called bleachbit that appears to be similar to sweeper.
Haven’t tried it out myself though.

It doesn’t work neither, I think it is a privacy concern.

Since the history is specific to each user, each user should have there own password and user name. This reduces some what the privacy concerns. Root can of course stil dig up the data.

Since it is user specific the actual files holding the info should be some where in the users home probably with the rest of the KDE settings and data

Does turning off the feature also still allow the history to accumulate? Or is it just tuning it on again shows the previous pre turn off history??

Yes, if you turn off the feature of recent documents and recent saved it only hide it, it doesn’t stop of registering the activity, if you enable the feature again it will show all the activity

Sounds like a bug need to be sent to KDE people. But then you should not let different users use the same user name and password.

It should be possible to disable this in “Configure Desktop”->“Workspace Behavior”->“Activities”->“Privacy”.
Never tried that myself though, so I cannot guarantee that it will work.

Regarding sweeper: it has been ported to KF5, but not released yet. Although I’m not sure that it has been adapted to clear out the new recent documents system already.