Getting past Install partitioning recommends with 11.1

I have deleted a 98GB windows partition sda2 and plan to :

  1. Re-install 11.1 into sda2
  2. sda1 & sda3 are Toshiba recovery & Toshiba restore not to be altered
  3. sda4 is extended
  4. sda5 is vfat32 with important data not be touched
  5. sda6 is swap
  6. sda7 is Linux 11.1 currently used not to be touched or mounted
    and has a size of 19GB

During several different trials (each aborted due to eronious install recommends)

  1. Installer suggests:
    1a) Delete sda7 & format as root / at 6GB down from 19GB
    1b) Delete sda6 & reformat as swap
    1c) mount sda3 & sda5 as /windows/C & /windows/E
    1d) Create sda8 @ 11GB which was part of sda7 and make it /home
    1e) ignore sda2 leaving it unallocated

Tried to create custom partitioning

  1. Don’t format sda7, Don’t mount sda7
  2. Don’t format sda8, Don’t mount sda8
  3. delete sda8
  4. resize sda7 back to 19GB
  5. Format sda2 as root /

Install changed to:

  1. Delete sda7 create sda7 as /home and Format it @ 6GB
  2. Delete sda8 create sda8 as /usr and format it @ 11GB
  3. Delete sda6 create sda6 as swap and format it
  4. Create sda2 as root /
  5. Mount sda3 and sda5 as /windows/C and windows/D

How can I force the system to only use sda2 and sda6 and leave everything else alone so I can after the install mount sda7 and
sda5 copy needed info to sda2 /home and rebuild the extended partition?

any idea’s on overriding the install please:\


choose the “expert” option - that makes no suggestions (i.e. assumes you are an “expert” - or at least know what you want to do :))

you can then just choose the 2 partitions you want to use as /swap and / and not touch the rest


Why reinstall at all?

Linux does not care (in contrast to windows) if it is installed on a logical partition.

I would use sda2 as a new data partition and leave the rest untouched.

With 19G on sda7 you certainly won’t run into problems with free space for /.

took 7 times using expert before the ADD button was present. Was using expert all the time but finally on 7th try the add button showed thereby allowing me to select sda2 as partition leaving all else alone. Worked great!


I realize Linux is able to use any partition but I felt my reasons for cleaning up system were justified, your opinion is taken into consideration and I thank you. Here are my reasons…

  1. Could not get system to allow desktop choice kde or gnome
  2. kde 4.1 was acting up and Yast wouldn’t allow me to change to kde 4.3
  3. wanted to make more space for trying out Virtualhost to install/run windows in virtual mode
  4. wanted to see if xbasic would run under kde 4.3 cause it doesn’t work (form designer part) under kde 4.1
  5. Don’t need Toshiba restore as it’s on DVD (makes another 6GB avail)
  6. Tried out gambas2 and x86asm and tried to work through opensuse build service but system was complaining sda7 had insufficient space to comply with build service although both packages did make it through beta testing and rpm builds of new developed software.

So there are my thoughts

And none of those reasons are of any real relevance for a reinstall.

Relevant or not my 35 years with systems has prevailed

got openSUSE onto sda2 sucessfully

  1. Have choice kde or gnome now
  2. kde 4.3 installed and working 1000% better than 4.1
  3. lots of space for trying out Virtualhost to install/run windows in virtual mode
  4. xbasic runs under kde 4.3 totally without error
  5. ready to remove Toshiba restore partition
  6. gambas2 and x86asm have no further complaints but now need to check this against build service.
  7. soon will be able to convert old extended partition into clean storage space

Thanks for your opinion though