Getting my wireless to start automatically--How?

Here is what I have to do when I boot up…

1.open a terminal as root.
2. # modprobe ath_pci
3. # /sbin/ifconfig
4. # NetworkManager

Then close the console…

go to network manager on the panel and connect to my router.

Is there a way to not have to do all this? :\

Of course.

Go into Yast, then Network Devices, then Network Settings. Select your wireless device, and then choose to edit (or add, if it doesn’t exist). Select the hardware tab, and then choose ath_pci under the module name. Go to the general tab, and choose to start the device at boot time. On the device tab, choose to get your address via dhcp.

Then, set it up under KNetworkManager. I assume you know how to do this from your post. Make sure to choose “save and connect” at the end of configuration, and make sure to choose the “connect automatically” box at the end.

goldstar1 wrote:
> Here is what I have to do when I boot up…
>
> 1.open a terminal as root.
> 2. # modprobe ath_pci

This one is easy; however, I don’t know why it is not automatic.
Assuming you have a KDE desktop, click on the chameleon (Start),
select computer, and click on “Administrator Settings”. (This is
usually abbreviated as “Start YaST”.) In the YaST Control Center,
click on System in the left section and on /etc/sysconfig Editor on
the right. In the left panel, open System (click on the +), then open
Kernel and click on MODULES_LOADED_ON_BOOT. In the right-hand panel,
enter ath_pci in the box.

> 3. # /sbin/ifconfig

Use an editor (as root) to add this line to /etc/init.d/boot.local.

> 4. # NetworkManager

Ditto.

>
> Then close the console…
>
> go to network manager on the panel and connect to my router.
>
> Is there a way to not have to do all this? :
>
>

For most people, setting NM to control your devices and setting the
autoconnect button in the connection settings is sufficient.

I would try doing the stuff under step 2, and then reboot to see if
that is all that it takes.

Larry