Getting Mobile Broadband to Work with NetworkManager on open

Some might have noticed that on openSUSE 11.1, NetworkManager isn’t able to connect to the internet with their mobile broadband device. The reason for this is the bundling of NetworkManager with ModemManager which currently doesn’t support some mobile broadband devices which worked with NetworkManager without ModemManager. The long term solution is to get these cards to work in ModemManager, but for now the better solution for some is NetworkManager built without ModemManager.

Below, I have listed the link to an OBS repository I have made for NetworkManager rebuilt without ModemManager. By installing these rebuilt packages, your mobile broadband device should now work, assuming it worked with NetworkManager before. If your mobile broadband device doesn’t work with the NetworkManager packages bundled on openSUSE 11.1 please make note of it in this thread. Also, if it doesn’t work with the packages bundled with openSUSE 11.1 or these packages make note of it in this thread as well.

Repository Link:

Index of /repositories/home:/jb7852:/networkmanager/openSUSE_11.1

How do I check that the correct version of NM is running ?


rpm -qa "*NetworkManager*"

zypper se -su NetworkManager 

I installed a new 11.2 and now my huawei e1692 works (thanks to huawei e1692 don’t work - openSUSE Forums).
kde=Versione 4.3.4 (KDE 4.3.4) “release 2”
kernel=2.6.31.5-0.1-desktop
NetworkManager | Network Link Manager and User Applica… | 0.7.1_git20090811-4.2
NetworkManager-kde4 | NetworkManager client for KDE 4 | 0.9.svn1043876-4.7

huawei e1692 works, but if I manage connections with knetworkmanager the broadband tab is grey and not clikable, how can I connect by knetworkmanager?